Bug 865968 - SELinux is preventing /opt/Citrix/ICAClient/wfica from 'read' accesses on the file /opt/Citrix/ICAClient/keystore/cacerts/Equifax_Secure_Certificate_Authority_DER.cer.
SELinux is preventing /opt/Citrix/ICAClient/wfica from 'read' accesses on the...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1202ecae44e86ee64eac1479ad5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 19:11 EDT by Kevin Below
Modified: 2012-10-15 10:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 10:18:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-12 19:11 EDT, Kevin Below
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-12 19:11 EDT, Kevin Below
no flags Details

  None (edit)
Description Kevin Below 2012-10-12 19:11:30 EDT
Additional info:
libreport version: 2.0.14
kernel:         3.6.1-1.fc17.i686

description:
:SELinux is preventing /opt/Citrix/ICAClient/wfica from 'read' accesses on the file /opt/Citrix/ICAClient/keystore/cacerts/Equifax_Secure_Certificate_Authority_DER.cer.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that wfica should be allowed read access on the Equifax_Secure_Certificate_Authority_DER.cer file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep wfica /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:admin_home_t:s0
:Target Objects                /opt/Citrix/ICAClient/keystore/cacerts/Equifax_Sec
:                              ure_Certificate_Authority_DER.cer [ file ]
:Source                        wfica
:Source Path                   /opt/Citrix/ICAClient/wfica
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           ICAClient-12.1.0-0.i386
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-153.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.1-1.fc17.i686 #1 SMP Wed Oct
:                              10 12:56:16 UTC 2012 i686 i686
:Alert Count                   36
:First Seen                    2012-10-12 10:00:44 EDT
:Last Seen                     2012-10-12 18:48:20 EDT
:Local ID                      17ee610c-1d82-4fe2-94b6-ef09d23831f8
:
:Raw Audit Messages
:type=AVC msg=audit(1350082100.313:140): avc:  denied  { read } for  pid=3136 comm="wfica" name="Equifax_Secure_Certificate_Authority_DER.cer" dev="dm-1" ino=3177 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1350082100.313:140): arch=i386 syscall=open per=400000 success=no exit=EACCES a0=b1a3d968 a1=0 a2=1b6 a3=b6b240d0 items=0 ppid=3039 pid=3136 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=wfica exe=/opt/Citrix/ICAClient/wfica subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: wfica,mozilla_plugin_t,admin_home_t,file,read
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t admin_home_t:file read;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t admin_home_t:file read;
:
Comment 1 Kevin Below 2012-10-12 19:11:33 EDT
Created attachment 626337 [details]
File: type
Comment 2 Kevin Below 2012-10-12 19:11:34 EDT
Created attachment 626339 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-10-15 10:18:29 EDT
This looks like a mislabling problem.

restorecon -R -v /opt

Note You need to log in before you can comment on or make changes to this bug.