Bug 865974 - Removal of a mapi account, does not remove mapi calendar.
Removal of a mapi account, does not remove mapi calendar.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-mapi (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 20:39 EDT by William Brown
Modified: 2012-10-22 11:49 EDT (History)
2 users (show)

See Also:
Fixed In Version: evolution-3.6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 11:49:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Brown 2012-10-12 20:39:51 EDT
Description of problem:
After a mapi account is created, the calendar is creates has no delete option. Removing the mapi account associated with this calendar does not remove the calendar either. 


Version-Release number of selected component (if applicable):
3.4.4


How reproducible:
Always


Steps to Reproduce:
1. Add mapi account
2. Remove mapi account

Actual results:
Calendar remains, and cannot be deleted

Expected results:
Calendar should be able to be removed, or should be removed when mapi account is removed.
Comment 1 Milan Crha 2012-10-22 11:49:34 EDT
Thanks for a bug report. I tried to reproduce this, with evolution 3.4.4, but with no luck. I created MAPI account, then new calendar group had been added, then I removed the account (it was still enabled in Edit->Preferences->Mail Accounts) and the whole calendar group was removed too. I tried the same with whole machine restart after adding the MAPI account, but the calendar was still removed as expected. Despite the fact me being unable to reproduce this, I know it can happen from time to time, but the exact circumstances for a reproducer are currently unknown to me. There were similar issues when using multiple ESourceList-s and EAccountList-s, while there should be used only one in an application, especially when changing its content.

The current stable, which is 3.6.1 - part of Fedora 18, has these internals rewritten from scratch, thus I guess the rewrite also, as a side-effect, fixes this issue. Please reopen, if you'll see this in 3.6.1+. Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.