Bug 866011 - SELinux is preventing /usr/sbin/php-fpm from 'read' accesses on the file meminfo.
SELinux is preventing /usr/sbin/php-fpm from 'read' accesses on the file memi...
Status: CLOSED DUPLICATE of bug 866010
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:683f5cb77ca569b0e3a7c50f56f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 05:03 EDT by Mikhail
Modified: 2012-10-15 05:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 05:50:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-13 05:03 EDT, Mikhail
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-13 05:03 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-10-13 05:03:24 EDT
Additional info:
libreport version: 2.0.16
kernel:         3.6.1-1.fc18.i686.PAE

description:
:SELinux is preventing /usr/sbin/php-fpm from 'read' accesses on the file meminfo.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that php-fpm should be allowed read access on the meminfo file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep php-fpm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:phpfpm_t:s0
:Target Context                system_u:object_r:proc_t:s0
:Target Objects                meminfo [ file ]
:Source                        php-fpm
:Source Path                   /usr/sbin/php-fpm
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           php-fpm-5.4.7-10.fc18.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-36.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.1-1.fc18.i686.PAE #1 SMP Mon
:                              Oct 8 17:41:46 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    2012-10-13 04:11:19 YEKT
:Last Seen                     2012-10-13 04:11:19 YEKT
:Local ID                      b57cf56b-6f6a-4707-a9c3-9728bde9cd66
:
:Raw Audit Messages
:type=AVC msg=audit(1350079879.724:662): avc:  denied  { read } for  pid=25503 comm="php-fpm" name="meminfo" dev="proc" ino=4026532026 scontext=system_u:system_r:phpfpm_t:s0 tcontext=system_u:object_r:proc_t:s0 tclass=file
:
:
:type=AVC msg=audit(1350079879.724:662): avc:  denied  { open } for  pid=25503 comm="php-fpm" path="/proc/meminfo" dev="proc" ino=4026532026 scontext=system_u:system_r:phpfpm_t:s0 tcontext=system_u:object_r:proc_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1350079879.724:662): arch=i386 syscall=open success=yes exit=ESRCH a0=4c1ed2c2 a1=80000 a2=1b6 a3=a36fe28 items=0 ppid=1 pid=25503 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=php-fpm exe=/usr/sbin/php-fpm subj=system_u:system_r:phpfpm_t:s0 key=(null)
:
:Hash: php-fpm,phpfpm_t,proc_t,file,read
:
:audit2allow
:
:#============= phpfpm_t ==============
:allow phpfpm_t proc_t:file { read open };
:
:audit2allow -R
:
:#============= phpfpm_t ==============
:allow phpfpm_t proc_t:file { read open };
:
Comment 1 Mikhail 2012-10-13 05:03:27 EDT
Created attachment 626447 [details]
File: type
Comment 2 Mikhail 2012-10-13 05:03:30 EDT
Created attachment 626448 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-15 05:50:05 EDT

*** This bug has been marked as a duplicate of bug 866010 ***

Note You need to log in before you can comment on or make changes to this bug.