This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 866044 - sympy-0.7.2 is available
sympy-0.7.2 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sympy (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On: 974769
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-13 07:52 EDT by Upstream Release Monitoring
Modified: 2013-07-11 23:17 EDT (History)
3 users (show)

See Also:
Fixed In Version: sympy-0.7.2-1.fc19
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 23:17:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2012-10-13 07:52:45 EDT
Latest upstream release: 0.7.2.rc1
Current version in Fedora Rawhide: 0.7.1
URL: http://code.google.com/p/sympy/downloads/list

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2012-10-17 04:07:01 EDT
Latest upstream release: 0.7.2
Current version in Fedora Rawhide: 0.7.1
URL: http://code.google.com/p/sympy/downloads/list

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 2 katastrophal 2012-12-07 19:31:46 EST
This Release would add python 3 support and would be really appreciated :-)
Comment 3 Fedora Admin XMLRPC Client 2013-03-04 14:03:02 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Tadej Janež 2013-05-25 06:31:26 EDT
Jerry, please update sympy to 0.7.2.

Also, the URL is now: http://sympy.org/.
Comment 5 Jerry James 2013-06-18 18:07:25 EDT
Here is where things stand.  I have been waiting for python-pyglet to be available due to bug 890312.  The process of getting it into Fedora took much longer than I anticipated.  Sorry for the delay.

I have updated the spec file for 0.7.2, have packaged the TeXmacs plugin, built the documentation for all available languages (in a -doc subpackage), and packaged the examples (in an -examples) subpackage.

Now the package won't build because the documentation building step needs LaTeX, and the texlive packages are currently broken in Rawhide due to the recent gd update.  Hopefully texlive will be rebuilt in the next few days.

We also have a problem with mpmath (caused by sagemath?); see bug 974769.  For me, this bug prevents any use of sympy at all, and also kills local (non-mock) builds.

I also haven't figured out how to build for python3 yet.  It shouldn't be too hard, except that there is no python3 build of pyglet.  I will get that figured out while the other bugs are being worked on, but those of you waiting for a python3 build just have to understand that pyglet is unavailable, so don't do anything that requires it. :-)
Comment 6 Tadej Janež 2013-06-19 13:52:44 EDT
Jerry,

thanks for an update.

(In reply to Jerry James from comment #5)
> I have updated the spec file for 0.7.2, have packaged the TeXmacs plugin,
> built the documentation for all available languages (in a -doc subpackage),
> and packaged the examples (in an -examples) subpackage.

Great news.

> Now the package won't build because the documentation building step needs
> LaTeX, and the texlive packages are currently broken in Rawhide due to the
> recent gd update.  Hopefully texlive will be rebuilt in the next few days.

Agreed, I hope this will be resolved soon.

> We also have a problem with mpmath (caused by sagemath?); see bug 974769. 
> For me, this bug prevents any use of sympy at all, and also kills local
> (non-mock) builds.

Speaking of mpmath, I tried to convince the upstream to at least offer the option of using an external version of mpmath (to avoid the heavy patch that our package carries now):
http://code.google.com/p/sympy/issues/detail?id=2482#c43

There has been some progress on this today with a new pull request on GitHub to unbundle mpmath:
https://github.com/sympy/sympy/pull/2192

This of course will not happen before 0.7.3, but it is a step in the right direction.
Comment 7 Jerry James 2013-06-19 15:22:08 EDT
(In reply to Tadej Janež from comment #6)
> Speaking of mpmath, I tried to convince the upstream to at least offer the
> option of using an external version of mpmath (to avoid the heavy patch that
> our package carries now):
> http://code.google.com/p/sympy/issues/detail?id=2482#c43
> 
> There has been some progress on this today with a new pull request on GitHub
> to unbundle mpmath:
> https://github.com/sympy/sympy/pull/2192
> 
> This of course will not happen before 0.7.3, but it is a step in the right
> direction.

Excellent!  Thanks for doing that, Tadej.  That will make migrating to future versions much easier.
Comment 8 Fedora Update System 2013-07-01 19:09:25 EDT
sympy-0.7.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sympy-0.7.2-1.fc19
Comment 9 Jerry James 2013-07-01 19:12:12 EDT
Sympy 0.7.2 has now been built for Rawhide and F-19.  I cannot yet build a python3 version due to missing python3 dependencies (mpmath and pyglet), but will do so as soon as I can.  There is still some kind of bug with mpmath and sagemath (bug 974769).
Comment 10 Fedora Update System 2013-07-02 21:38:12 EDT
Package sympy-0.7.2-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sympy-0.7.2-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12154/sympy-0.7.2-1.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-07-11 23:17:03 EDT
sympy-0.7.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.