Bug 866173 - webadmin: no information is shown on snapshots on upgraded setup (3.0 to 3.1) incl. new snapshots
webadmin: no information is shown on snapshots on upgraded setup (3.0 to 3.1)...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
urgent Severity high
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
vvyazmin@redhat.com
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 09:08 EDT by Dafna Ron
Modified: 2016-02-10 14:54 EST (History)
11 users (show)

See Also:
Fixed In Version: SI24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:07:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shots (144.40 KB, application/x-gzip)
2012-10-14 09:08 EDT, Dafna Ron
no flags Details
db dump (227.39 KB, application/x-xz)
2012-10-22 08:21 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-10-14 09:08:27 EDT
Created attachment 626926 [details]
screen shots

Description of problem:

I have a setup upgraded from 3.0 and no information is shown on any of the snapshots when they are selected. 
it's for existing vm's and new ones created from blank template. 

I tested the same on a clean install and we can see the info on a clean setup. 

Version-Release number of selected component (if applicable):

si20 upgraded from 3.0

How reproducible:

100%

Steps to Reproduce:
1. upgrade 3.0 to 3.1
2. select a vm with snapshots 
3. create a new vm -> create a new snapshot and select it
  
Actual results:

no information is shown on the snapshots in the general/disks/network atc.

Expected results:

we should see information on snapshot

Additional info: screen shots from clean setup and upgraded one
Comment 2 Ayal Baron 2012-10-16 10:18:35 EDT
Dafna, can you attach a db dump?
Comment 3 Dafna Ron 2012-10-16 10:37:08 EDT
since its a webadmin bug I did not attach any logs and db dump is was not requested. 
since I still have the same setup please tell me what you need me to do and I will attach it.
Comment 4 Asaf Shakarchi 2012-10-22 05:57:50 EDT
Please attach a db dump, thanks.
Comment 5 Dafna Ron 2012-10-22 08:21:05 EDT
Created attachment 631457 [details]
db dump
Comment 6 Asaf Shakarchi 2012-10-28 10:07:25 EDT
Since engine v3.0 didn't support full snapshots it is impossible to reflect any of it in the new 3.1 UI,

Thus I suggest to display a message which indicates that the information is unavailable.
Comment 7 Ayal Baron 2012-10-28 18:53:32 EDT
(In reply to comment #6)
> Since engine v3.0 didn't support full snapshots it is impossible to reflect
> any of it in the new 3.1 UI,
> 
> Thus I suggest to display a message which indicates that the information is
> unavailable.

Iirc upgrade also updates the snapshots info?
what info is in the db?
Comment 8 Asaf Shakarchi 2012-10-29 07:02:48 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > Since engine v3.0 didn't support full snapshots it is impossible to reflect
> > any of it in the new 3.1 UI,
> > 
> > Thus I suggest to display a message which indicates that the information is
> > unavailable.
> 
> Iirc upgrade also updates the snapshots info?
> what info is in the db?
An entry per snapshot in the new snapshot table without the blob which contains the ovf.
Comment 9 Ayal Baron 2012-10-29 07:18:10 EDT
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > Since engine v3.0 didn't support full snapshots it is impossible to reflect
> > > any of it in the new 3.1 UI,
> > > 
> > > Thus I suggest to display a message which indicates that the information is
> > > unavailable.
> > 
> > Iirc upgrade also updates the snapshots info?
> > what info is in the db?
> An entry per snapshot in the new snapshot table without the blob which
> contains the ovf.

Then can we fix upgrade to include the same (latest) ovf for all the snapshots?
Comment 10 Asaf Shakarchi 2012-10-29 07:26:07 EDT
(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #7)
> > > (In reply to comment #6)
> > > > Since engine v3.0 didn't support full snapshots it is impossible to reflect
> > > > any of it in the new 3.1 UI,
> > > > 
> > > > Thus I suggest to display a message which indicates that the information is
> > > > unavailable.
> > > 
> > > Iirc upgrade also updates the snapshots info?
> > > what info is in the db?
> > An entry per snapshot in the new snapshot table without the blob which
> > contains the ovf.
> 
> Then can we fix upgrade to include the same (latest) ovf for all the
> snapshots?
I guess so but IMO it isn't the appropriate solution, this misleads the admin with wrong information.
Comment 11 Ayal Baron 2012-10-29 22:24:27 EDT
(In reply to comment #10)
> (In reply to comment #9)
> > (In reply to comment #8)
> > > (In reply to comment #7)
> > > > (In reply to comment #6)
> > > > > Since engine v3.0 didn't support full snapshots it is impossible to reflect
> > > > > any of it in the new 3.1 UI,
> > > > > 
> > > > > Thus I suggest to display a message which indicates that the information is
> > > > > unavailable.
> > > > 
> > > > Iirc upgrade also updates the snapshots info?
> > > > what info is in the db?
> > > An entry per snapshot in the new snapshot table without the blob which
> > > contains the ovf.
> > 
> > Then can we fix upgrade to include the same (latest) ovf for all the
> > snapshots?
> I guess so but IMO it isn't the appropriate solution, this misleads the
> admin with wrong information.

I disagree, that is the info we have, without it the snapshots are totally broken in which case the solution would be to delete them (not an acceptable solution).
Comment 12 Asaf Shakarchi 2012-10-30 23:43:35 EDT
(In reply to comment #11)
> (In reply to comment #10)
> > (In reply to comment #9)
> > > (In reply to comment #8)
> > > > (In reply to comment #7)
> > > > > (In reply to comment #6)
> > > > > > Since engine v3.0 didn't support full snapshots it is impossible to reflect
> > > > > > any of it in the new 3.1 UI,
> > > > > > 
> > > > > > Thus I suggest to display a message which indicates that the information is
> > > > > > unavailable.
> > > > > 
> > > > > Iirc upgrade also updates the snapshots info?
> > > > > what info is in the db?
> > > > An entry per snapshot in the new snapshot table without the blob which
> > > > contains the ovf.
> > > 
> > > Then can we fix upgrade to include the same (latest) ovf for all the
> > > snapshots?
> > I guess so but IMO it isn't the appropriate solution, this misleads the
> > admin with wrong information.
> 
> I disagree, that is the info we have, without it the snapshots are totally
> broken in which case the solution would be to delete them (not an acceptable
> solution).
True, so here's a final clarification for this bug:

Full snapshot confiugration wasn't supported in Engine v3,

Snapshot preview in v3 uses the current VM details, network interfaces combined with the snapshot disks.

So for snapshots taken in v3 after upgrade, the same exact info should be used in engine v3.1 and above

In case dealing with old snapshots, current VM details and network interfaces will be loaded from the database, combined with the snapshot disk images.
Comment 13 Asaf Shakarchi 2012-11-01 14:58:48 EDT
Patch submitted:

http://gerrit.ovirt.org/#/c/8981/
Comment 14 Daniel Erez 2012-11-04 07:00:28 EST
Merged Iddfae10354603e2ec9acb61f91e1361dd7504da4
Comment 15 Daniel Paikov 2012-11-13 08:07:59 EST
Checked on si24.1.

Note You need to log in before you can comment on or make changes to this bug.