Bug 866192 - oVirt Node ISO 2.5.2 does not have the hostname command
oVirt Node ISO 2.5.2 does not have the hostname command
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.1 GA
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mike Burns
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 11:43 EDT by Ade Bradshaw
Modified: 2016-04-26 13:53 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 21:47:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Bradshaw 2012-10-14 11:43:31 EDT
Description of problem:
The hostname command is missing. 


Version-Release number of selected component (if applicable):
2.5.2 iso dated  (http://ovirt.org/releases/3.1/tools/ovirt-node-iso-2.5.2-0.1.fc17.iso)

How reproducible:
100%

Steps to Reproduce:
1. install ovirt node
2. configure it
3. when going to configure networkcard, it offers to save changes (such as the hostname you entered) - then you get an error about hostname command is missing
4. press F2 to go to commandline - "which hostname" fails to find it and typing "hostname" also fails
  
Actual results:
the node remains with a hostname of localhost.localdomain (even though the /etc/sysconfig/network has the correct setting)

Expected results:
the hostname would be the one you entered in the config interface


Additional info:
Comment 1 Mike Burns 2012-10-14 21:47:00 EDT
Fixed in next release:  

http://gerrit.ovirt.org/#/c/8540/  2.5 branch
http://gerrit.ovirt.org/#/c/7296/ 2.6 branch

Note You need to log in before you can comment on or make changes to this bug.