Bug 866196 - oVirt node install doesnt set virt_use_sanlock on
oVirt node install doesnt set virt_use_sanlock on
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.1 GA
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mike Burns
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 11:49 EDT by Ade Bradshaw
Modified: 2016-04-26 09:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: 2.6.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 08:38:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ade Bradshaw 2012-10-14 11:49:42 EDT
Description of problem:
oVirt Node ISO install does not set the virt_use_sanlock to on

Version-Release number of selected component (if applicable):
2.5.2 http://ovirt.org/releases/3.1/tools/ovirt-node-iso-2.5.2-0.1.fc17.iso

How reproducible:
100%

Steps to Reproduce:
1. Install and configure the Node
2. Create a VM on a SAN (I was using iSCSI)
3. VM wont start, error message about sanlock appears
  
Actual results:
VMs on an iSCSI storage domain wont start

Expected results:
VMs on an iSCSI storage domain DO start

Additional info:
Pressing F2 on the admin interface of the node and doing setsebool virt_use_sanlock 1 resolves the issue but doesnt survive a reboot (even with -P)
Comment 1 Mike Burns 2012-10-14 21:54:56 EDT
Patching for the short term, but eventually, a vdsm plugin package should handle this.

http://gerrit.ovirt.org/8542
Comment 2 Mike Burns 2013-02-13 08:38:17 EST
This bug has been fixed in the 2.6.0 release of ovirt-node, which is now available on both ovirt.org and in Fedora 18
Comment 3 Sander 2013-10-17 07:08:20 EDT
Bug seems to be back in ovirt-node-iso-3.0.1-1.0.2.vdsm.el6.iso plugin version ovirt-node-plugin-vdsm-0.1.1-4.el6.noarch using FC storage.

Note You need to log in before you can comment on or make changes to this bug.