Bug 866232 - Incorrect detecting monitor resolution
Incorrect detecting monitor resolution
Status: CLOSED DUPLICATE of bug 699705
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 14:23 EDT by Ivan Romanov
Modified: 2013-01-04 16:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-04 16:20:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci output (1.50 KB, application/octet-stream)
2012-10-14 14:23 EDT, Ivan Romanov
no flags Details
dmesg output (61.50 KB, application/octet-stream)
2012-10-14 14:26 EDT, Ivan Romanov
no flags Details
Xorg.log (117.25 KB, text/x-log)
2012-10-14 14:29 EDT, Ivan Romanov
no flags Details
xrandr after cvt and xrandr (957 bytes, application/octet-stream)
2012-10-16 21:30 EDT, Ivan Romanov
no flags Details
xrandr --verbose after cvt and xrandr (8.58 KB, application/octet-stream)
2012-10-16 22:04 EDT, Ivan Romanov
no flags Details
xrandr --verbose DNS G236 (5.63 KB, application/octet-stream)
2012-10-17 07:18 EDT, Ivan Romanov
no flags Details
xorg.log DNS G236 (104.28 KB, text/x-log)
2012-10-17 07:19 EDT, Ivan Romanov
no flags Details
dmesg DNS G236 (59.54 KB, application/octet-stream)
2012-10-17 07:20 EDT, Ivan Romanov
no flags Details

  None (edit)
Description Ivan Romanov 2012-10-14 14:23:05 EDT
Created attachment 627084 [details]
lspci output

I use a netbook with Intel GMA 3150. When I connect Samsung SyncMaster B2430 monitor to the netbook it setup bad resolution. Maximum availabled resolution is 1024x768 but in really the monitor works with 1920x1080.

I've setuped such resolution with xrandr --newmode it's work fine. But I want to autodetect of all supported resolutions.
Comment 1 Ivan Romanov 2012-10-14 14:26:10 EDT
Created attachment 627085 [details]
dmesg output
Comment 2 Ivan Romanov 2012-10-14 14:29:15 EDT
Created attachment 627086 [details]
Xorg.log
Comment 3 Adam Jackson 2012-10-16 16:15:57 EDT
I don't follow.  Where are you looking that "maximum available resolution" is 1024x768?  Your X log certainly sees 1920x1080 modes.

Can you attach the output of xrandr --verbose ?
Comment 4 Ivan Romanov 2012-10-16 21:30:10 EDT
Created attachment 628491 [details]
xrandr after cvt and xrandr
Comment 5 Ivan Romanov 2012-10-16 21:35:44 EDT
First when I connected my monitor in first time I got 1024x768 resoulution. 
I coulnd't choose resolution more than 1024x768. It's mean that xrandr shows maximum 1024x768.
Then I use cvt and xrandr to setup new resoulution. So I got 1920x1080.
Now when i'm doing xrandr i get many new resoulutions which i didn't see before. It's weird for me. I will tried it from live usb. Maybe i can reproduce it.
Comment 6 Ivan Romanov 2012-10-16 22:04:56 EDT
Created attachment 628493 [details]
xrandr --verbose after cvt and xrandr
Comment 7 Ivan Romanov 2012-10-17 07:17:26 EDT
hm .... weird.
I loaded Fedora 17 Gnome LiveCD. connect my DNS G236 monitor and got a wrong picture on both monitor and netbook displays.
Comment 8 Ivan Romanov 2012-10-17 07:18:41 EDT
Created attachment 628700 [details]
xrandr --verbose DNS G236
Comment 9 Ivan Romanov 2012-10-17 07:19:17 EDT
Created attachment 628701 [details]
xorg.log DNS G236
Comment 10 Ivan Romanov 2012-10-17 07:20:21 EDT
Created attachment 628702 [details]
dmesg DNS G236
Comment 11 Adam Jackson 2013-01-04 16:20:33 EST
(In reply to comment #7)
> hm .... weird.
> I loaded Fedora 17 Gnome LiveCD. connect my DNS G236 monitor and got a wrong
> picture on both monitor and netbook displays.

Yeah, sorry, your GPU is lame.  It can't draw 3d to surfaces that are more than 2048 wide.  See the duplicate bug for details.

*** This bug has been marked as a duplicate of bug 699705 ***

Note You need to log in before you can comment on or make changes to this bug.