Bug 866250 - gnome-shell wont start with external monitor connected
gnome-shell wont start with external monitor connected
Status: CLOSED DUPLICATE of bug 699705
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 16:23 EDT by Dave Mitchell
Modified: 2012-10-16 16:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 16:49:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages from boot to shutdown (89.86 KB, application/octet-stream)
2012-10-14 16:23 EDT, Dave Mitchell
no flags Details

  None (edit)
Description Dave Mitchell 2012-10-14 16:23:59 EDT
Created attachment 627119 [details]
/var/log/messages from boot to shutdown

Description of problem:

If laptop is booted with external VGA monitor connected, system hangs or crashes after login. Conversely, connecting the external monitor works fine *after* login.


Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.20.8-1.fc17.x86_64

How reproducible:


Steps to Reproduce:
1. Connect external monitor.
2. Power on, wait for boot
3. Login
  
Actual results:

varies, but typically external monitor is blank, laptop screen just displays
fedora background. Mouse moves (including off-screen into notional external
monitor area), but 'windows' activity button won't bring up gnome-shell,
and the system seems generally dead. Other times random lines have appeared on the screen. This particular time, ctl-alt-del successfully brought up the power-off dialogue.


Expected results:

The system to be usable with external monitor.

Additional info:

Note that if the system is booted without the external monitor, then the monitor is connected *after* login, it works fine, with the desktop spread
across the two screens.
Possibly related is the fact the laptop won't suspend while the external monitor is connected.
This system is 5 years old, and has worked fine with fedora 14 and earlier.

$ lsmod|grep video
video                  18936  1 i915

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1980, maximum 4096 x 4096
LVDS1 connected 1440x900+0+1080 (normal left inverted right x axis y axis) 304mm x 19000mm
   1440x900       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+
   1680x1050      60.0  
   1680x945       60.0  
   1400x1050      60.0  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       74.9     59.8  
   1152x864       75.0  
   1280x768       74.9     59.9  
   1024x768       75.1     70.1     60.0  
   1024x576       60.0  
   800x600        72.2     75.0     60.3     56.2  
   848x480        60.0  
   640x480        72.8     75.0     60.0  
   720x400        70.1  
TV1 unknown connection (normal left inverted right x axis y axis)
   848x480        59.9 +
   640x480        59.9 +
   1024x768       59.9  
   800x600        59.9
Comment 1 Adam Jackson 2012-10-16 16:49:06 EDT
Oct 14 20:28:51 pigeon kernel: [    0.726783] agpgart-intel 0000:00:00.0: Intel 945GM Chipset

gen3 chips have 3d rendering limits that shell now tries harder to avoid.

*** This bug has been marked as a duplicate of bug 699705 ***

Note You need to log in before you can comment on or make changes to this bug.