Bug 866269 - rhn registration reports invalid credentials
rhn registration reports invalid credentials
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Mike Burns
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 20:47 EDT by Mike Burns
Modified: 2013-02-28 11:33 EST (History)
9 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-6.el6
Doc Type: Bug Fix
Doc Text:
When registering Red Hat Enterprise Virtualization Hypervisor to Red Hat Network (RHN) or the Subscription Manager, the registration failed with "invalid credentials". This was caused by a regression introduced by another fix where the passwords were masked in log files. The passwords were being submitted still masked. The solution was to duplicate the list values instead of having both the logging function and the authentication function share the same dataset.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:33:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-10-14 20:47:08 EDT
Description of problem:
when registering to RHN or SAM (and presumably Satellite, though I don't have it available to test), the registration fails with invalid permissions.

Version-Release number of selected component (if applicable):
ovirt-node-2.5.0-6

How reproducible:
Always

Steps to Reproduce:
1.provide correct credentials to rhn reg screen.
2.
3.
  
Actual results:
fails

Expected results:
succeeds

Additional info:

Issue is already debugged and a patch is in the works.  Previous changes to restrict the passwords from showing in log files caused the password to be passed to registration commands as "XXXXXX" instead of "password"
Comment 1 Mike Burns 2012-10-14 20:58:04 EDT
Patch:

http://gerrit.ovirt.org/8538
Comment 4 haiyang,dong 2012-10-30 01:47:56 EDT
Test version:
rhev-hypervisor6-6.4-20121015.1.el6
ovirt-node-2.5.0-7.el6_4.noarch

Tried:
1.registering to RHN  Pass

2012-10-30 05:26:02,565 - INFO - rhn - Registering to RHN account.....
2012-10-30 05:26:02,571 - DEBUG - rhn - ['/usr/sbin/rhnreg_ks', '--serverUrl', 'https://10.66.73.127/XMLRPC', '--sslCACert', '/etc/sysconfig/rhn/RHN-ORG-TRUSTED-SSL-CERT', '--username', 'ycui@redhat.com', '--password', 'XXXXXXX', '--profilename', 'redhat', '--proxy', '10.66.72.55:3128', '--proxyUser', 'www', '--proxyPassword', 'XXXXXXX', '--novirtinfo', '--norhnsd', '--nopackages', '--force']
2012-10-30 05:26:07,488 - DEBUG - rhn - Repository 'updates' is missing name in configuration, using id
Repository 'fedora' is missing name in configuration, using id

2.registering to SAM Pass

Registering to RHN account.....
['/usr/sbin/subscription-manager', 'register', '--username', 'admin', '--password', 'XXXXXXX', '--name', 'rhev-h', '--force', '--autosubscribe']
The system has been registered with id: 694676db-77b6-4558-9d9e-5bd5fb0aa467
Installed Product Current Status:

so that assign
logged_args = list(args)
any
operation you do on "logged_args", don't destroy the content of list "args",
so registering to RHN or SAM by using list "args" successfully

this bug has been fixed, change the status into "VERIFIED"
Comment 5 haiyang,dong 2012-12-26 06:19:56 EST
so follow steps of comment 4 to re-test on version
rhev-hypervisor6-6.4-20121212.1.el6 , bug was fixed on it.
Comment 7 errata-xmlrpc 2013-02-28 11:33:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.