Bug 866270 - Strings with failed save-operations disappear when using filtered view
Strings with failed save-operations disappear when using filtered view
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
1.7
Unspecified Unspecified
high Severity unspecified
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 20:53 EDT by Hedda Peters
Modified: 2013-02-25 22:46 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121127-0017)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hedda Peters 2012-10-14 20:53:32 EDT
Description of problem:
When using filters on the workspace (showing untranslated only) a failed save operation on a previously saved string means that this string disappears from the workspace when the workspace reloads. The steps to reproduce might make this clearer...


Version-Release number of selected component (if applicable):
noticed on translate.engineering.com

How reproducible:
occasionally

Steps to Reproduce:
1. open a workspace and apply filters (show only untranslated)
2. translate some strings to make them approved
3. go back to one of the now approved strings to correct a mistake you made
4. - occasionally the save operation of this re-editing of an approved string fails
  
Actual results:
If this save operation in step 4 fails, the workspace will reload. On the reloaded workspace, only untranslated strings appear according the the filters you set earlier. The string on which your edit failed disappeared. You'll have to change your filter options and use the search in order to find and re-do the edit.


Expected results:
The workspace shouldn't reload, to give you the chance to save your edit properly.

Additional info:
Comment 1 Michelle Kim 2012-11-12 20:16:54 EST
Hi Hedda,

Are you able to reproduce this bug in 2.0? I tried but wasn't able to. Please verify and let me know if this issue still exists in 2.0 onwards.

Thanks, Michelle
Comment 2 Hedda Peters 2012-11-12 20:23:42 EST
I can't reproduce a failed save operation. 

So I can't really verify if this issue, other than keeping my eye open.
Comment 3 Patrick Huang 2012-11-15 02:19:26 EST
With the 2.0 editor rewrite, a failed save will NOT trigger workspace reload. Verified locally.
Comment 5 Ding-Yi Chen 2012-11-27 00:21:12 EST
VERIFIED with Zanata version 2.0.3-SNAPSHOT (20121127-0017)

Note You need to log in before you can comment on or make changes to this bug.