Bug 866280 - kernel 3.7.0 reports "suspicious RCU usage"
kernel 3.7.0 reports "suspicious RCU usage"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 22:03 EDT by Michal Jaegermann
Modified: 2012-11-04 18:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-04 18:24:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full dmesg for 3.7.0-0.rc0.git6.2.fc19.x86_64 (52.86 KB, text/plain)
2012-10-14 22:05 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2012-10-14 22:03:23 EDT
Description of problem:

The following shows up after a boot:

[    1.218266] ===============================
[    1.218336] [ INFO: suspicious RCU usage. ]
[    1.218409] 3.7.0-0.rc0.git6.2.fc19.x86_64 #1 Not tainted
[    1.218481] -------------------------------
[    1.218553] include/linux/cgroup.h:566 suspicious rcu_dereference_check() usage!
[    1.218653] 
other info that might help us debug this:

[    1.218780] 
rcu_scheduler_active = 1, debug_locks = 0
[    1.218880] 2 locks held by kdevtmpfs/14:
[    1.218951]  #0:  (sb_writers){.+.+.+}, at: [<ffffffff811f5164>] mnt_want_write+0x24/0x50
[    1.219265]  #1:  (&sb->s_type->i_mutex_key#3/1){+.+.+.}, at: [<ffffffff811dfcb4>] kern_path_create+0x84/0x170
[    1.219647] 
stack backtrace:
[    1.219745] Pid: 14, comm: kdevtmpfs Not tainted 3.7.0-0.rc0.git6.2.fc19.x86_64 #1
[    1.219846] Call Trace:
[    1.219919]  [<ffffffff810d3e3d>] lockdep_rcu_suspicious+0xfd/0x130
[    1.220007]  [<ffffffff81304c5d>] devcgroup_inode_mknod+0x1ad/0x250
[    1.220085]  [<ffffffff812e1e08>] ? security_capable+0x18/0x20
[    1.220162]  [<ffffffff81076544>] ? ns_capable+0x44/0x80
[    1.220237]  [<ffffffff811e10ee>] vfs_mknod+0x7e/0x140
[    1.220312]  [<ffffffff8144ea57>] handle_create.isra.2+0x77/0x210
[    1.220390]  [<ffffffff810acbdf>] ? local_clock+0x6f/0x80
[    1.220465]  [<ffffffff810d2c2f>] ? lock_release_holdtime.part.26+0xf/0x180
[    1.220542]  [<ffffffff8144ed37>] devtmpfsd+0x147/0x170
[    1.220617]  [<ffffffff8144ebf0>] ? handle_create.isra.2+0x210/0x210
[    1.220695]  [<ffffffff81093b6d>] kthread+0xed/0x100
[    1.220770]  [<ffffffff81093a80>] ? flush_kthread_worker+0x190/0x190
[    1.220848]  [<ffffffff816f89ec>] ret_from_fork+0x7c/0x90
[    1.220923]  [<ffffffff81093a80>] ? flush_kthread_worker+0x190/0x190

Version-Release number of selected component (if applicable):
kernel-3.7.0-0.rc0.git6.2.fc19.x86_64

How reproducible:
so far seems to be repeatable
Comment 1 Michal Jaegermann 2012-10-14 22:05:20 EDT
Created attachment 627165 [details]
full dmesg for 3.7.0-0.rc0.git6.2.fc19.x86_64
Comment 2 Michal Jaegermann 2012-10-28 13:41:56 EDT
No changes up to and including 3.7.0-0.rc2.git3.1.fc19.x86_64
Comment 3 Michal Jaegermann 2012-11-04 18:24:22 EST
I do not see that anymore with 3.7.0-0.rc3.git4.2.fc19.x86_64.

Note You need to log in before you can comment on or make changes to this bug.