Bug 866285 - kernel fails to install from source due to issue with /etc/sysconfig/keyboard
kernel fails to install from source due to issue with /etc/sysconfig/keyboard
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-14 23:06 EDT by Dan Mashal
Modified: 2012-11-28 04:36 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-28 04:30:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mashal 2012-10-14 23:06:40 EDT
When running make install from kernel source the following error occurs:
 
sh /root/linux-3.6.2/arch/x86/boot/install.sh 3.6.2 arch/x86/boot/bzImage \
	System.map "/boot"
/etc/sysconfig/keyboard: line 1: vconsole.keymap=us: command not found

Steps to reproduce:

1) get latest kernel from kernel.org (3.6.1 or 3.6.2 in this case)
2) tar -zxvf linux-3.6.2.tar.gz
3) cd linux-3.6.2/
4) yum install @development-tools ncurses-devel -y
5) make mrproper
6) make oldconfig
7) make prepare
8) make menuconfig
9) choose options, save config
10) make
11) make modules_install
12) make bzImage
13) make install

receive error shown above.

Fix: copy /etc/sysconfig/keyboard from f17 which looks like:

KEYTABLE="us"
MODEL="pc105+inet"
LAYOUT="us"
Comment 1 Jens Petersen 2012-10-14 23:12:46 EDT
Might be helpful to see the make install output.
Comment 2 Dan Mashal 2012-10-14 23:23:11 EDT
Make install output is the following:

"sh /root/linux-3.6.2/arch/x86/boot/install.sh 3.6.2 arch/x86/boot/bzImage \
	System.map "/boot"
/etc/sysconfig/keyboard: line 1: vconsole.keymap=us: command not found"
Comment 3 Josh Boyer 2012-10-15 06:12:11 EDT
Installs call /sbin/installkernel which is provided by grubby.  Either grubby or dracut is spitting this error out.  It's not a kernel problem.
Comment 4 Dan Mashal 2012-10-15 09:20:26 EDT
thx.
Comment 5 Dan Mashal 2012-10-19 15:43:20 EDT
Sorry to be a pest but can someone provide an update on this please?
Comment 6 Bill Nottingham 2012-10-19 15:53:51 EDT
What does your /etc/sysconfig/keyboard look like?
Comment 7 Dan Mashal 2012-10-19 15:55:06 EDT
it was something like vconsole.keymap="us"
Comment 8 Dan Mashal 2012-10-22 22:31:07 EDT
This is causing multiple issues,

Gnome netinstall, compiling kernel, changing plymouth themes, etc.

Filing as a blocker along with related bugs.
Comment 9 Josh Boyer 2012-10-23 08:44:56 EDT
(In reply to comment #8)
> This is causing multiple issues,
> 
> Gnome netinstall, compiling kernel, changing plymouth themes, etc.

The kernel builds fine in Fedora.  It's not blocking F18 in that regard.
Comment 10 Dan Mashal 2012-10-24 18:25:28 EDT
You are right. I was merely pointing out the relationship between bugs.
Comment 11 Kevin Stange 2012-11-06 15:54:46 EST
I may be misunderstanding something... Why is this bug listed as being blocked by the F18Beta tracker bug?
Comment 12 Jens Petersen 2012-11-06 23:10:26 EST
No idea - I removed F18Beta.
Comment 13 Jens Petersen 2012-11-06 23:11:40 EST
Dan, if you want to escalate this you could propose it as a NTH
under F18-accepted.
Comment 14 Dan Mashal 2012-11-07 00:14:06 EST
Done and thanks. Removed the bug dependency and added both bugs as NTH.
Comment 15 Harald Hoyer 2012-11-19 08:35:45 EST
(In reply to comment #8)
> This is causing multiple issues,
> 
> Gnome netinstall, compiling kernel, changing plymouth themes, etc.
> 
> Filing as a blocker along with related bugs.

This misconfiguration is _not_ caused by dracut!
Comment 16 Bill Nottingham 2012-11-20 10:50:40 EST
This was a bug in an earlier anaconda build. However, I'm pretty sure it's been fixed. Can you reproduce this with current TC trees?
Comment 17 Dan Mashal 2012-11-20 11:02:42 EST
Will try
Comment 18 Adam Williamson 2012-11-27 04:49:15 EST
I'm not aware of anyone but Dan hitting this, so don't think it qualifies as a 'commonbug' as things stand. dropping keyword for now.
Comment 19 Chris Lumens 2012-11-27 09:13:48 EST
This was fixed by:

commit 96f844476268cefbc8779d037be386834974fd0a
Author: Bill Nottingham <notting@redhat.com>
Date:   Thu Oct 25 23:56:25 2012 -0400

    /etc/sysconfig/keyboard doesn't support vconsole.xyz options

Which was included in anaconda-18.22.
Comment 20 Dan Mashal 2012-11-27 17:46:57 EST
Thanks. Will test.
Comment 21 Dan Mashal 2012-11-28 04:30:00 EST
Confirmed the fix.

[root@f18 linux-3.6.8]# make install
sh /root/linux-3.6.8/arch/x86/boot/install.sh 3.6.8 arch/x86/boot/bzImage \
	System.map "/boot"
[root@f18 linux-3.6.8]#

Note You need to log in before you can comment on or make changes to this bug.