Bug 866290 - multipath -q does not work as promise
multipath -q does not work as promise
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: device-mapper-multipath (Show other bugs)
18
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-14 23:28 EDT by Xiaowei Li
Modified: 2015-01-26 19:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 14:13:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
multipath.log (12.42 KB, text/plain)
2012-10-14 23:29 EDT, Xiaowei Li
no flags Details

  None (edit)
Description Xiaowei Li 2012-10-14 23:28:41 EDT
Description of problem:


Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-29.fc18.x86_64

How reproducible:


Steps to Reproduce:
1. # multipath -t | grep -i daemon
	queue_without_daemon no
2. # multipath -q
   # echo $?
0
3. # multipath -t | grep -i daemon
	queue_without_daemon no
  
Actual results:


Expected results:
should change the queue_without_daemon to 'yes'

Additional info:
Comment 1 Xiaowei Li 2012-10-14 23:29:28 EDT
Created attachment 627171 [details]
multipath.log
Comment 2 Ben Marzinski 2012-10-15 14:13:19 EDT
I think there is a misunderstanding of what "-q" does.  It's not supposed to change the configuration, which is what you are checking with those commands. Normally, multipath won't set a device to queue at all if it's created when the
daemon is not running.  Not even queue_without_daemon will do that. It only keeps queueing enabled when the daemon stops.  It's for things like restarting
the daemon, where you don't want to lose your queueing in that window.  In normal
circumstances starting queueing without the daemon means that your device could get hung forever, since you can restore paths to the device without the daemon.

If you know that the daemon will be starting shortly, using the -q option is O.K.
this was necessary in the past.  However it is not in recent releases, so this option is only there for historical reasons.  It has no real use anymore.

Note You need to log in before you can comment on or make changes to this bug.