Bug 866314 - SELinux is preventing /usr/bin/systemctl from 'execute' accesses on the file /usr/bin/systemctl.
SELinux is preventing /usr/bin/systemctl from 'execute' accesses on the file ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:1b2a4a4d180c8e7dd3ddaf39555...
:
: 866315 866316 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 01:08 EDT by Stef Walter
Modified: 2012-12-20 09:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 09:59:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-15 01:08 EDT, Stef Walter
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-15 01:08 EDT, Stef Walter
no flags Details

  None (edit)
Description Stef Walter 2012-10-15 01:08:31 EDT
Description of problem:
realmd uses the 'systemctl' command to restart services.

Additional info:
libreport version: 2.0.16
kernel:         3.6.1-1.fc18.x86_64

description:
:SELinux is preventing /usr/bin/systemctl from 'execute' accesses on the file /usr/bin/systemctl.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemctl should be allowed execute access on the systemctl file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemctl /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:realmd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:systemd_systemctl_exec_t:s0
:Target Objects                /usr/bin/systemctl [ file ]
:Source                        systemctl
:Source Path                   /usr/bin/systemctl
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-194-1.fc18.x86_64
:Target RPM Packages           systemd-194-1.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-36.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.1-1.fc18.x86_64 #1 SMP Mon Oct
:                              8 17:19:09 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    2012-10-10 11:09:52 EDT
:Last Seen                     2012-10-15 01:06:25 EDT
:Local ID                      9105e8c5-6031-48d8-ab8a-beab4a99d960
:
:Raw Audit Messages
:type=AVC msg=audit(1350277585.224:370): avc:  denied  { execute } for  pid=3331 comm="realmd" name="systemctl" dev="sda3" ino=2230358 scontext=system_u:system_r:realmd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_systemctl_exec_t:s0 tclass=file
:
:
:type=AVC msg=audit(1350277585.224:370): avc:  denied  { read open } for  pid=3331 comm="realmd" path="/usr/bin/systemctl" dev="sda3" ino=2230358 scontext=system_u:system_r:realmd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_systemctl_exec_t:s0 tclass=file
:
:
:type=AVC msg=audit(1350277585.224:370): avc:  denied  { execute_no_trans } for  pid=3331 comm="realmd" path="/usr/bin/systemctl" dev="sda3" ino=2230358 scontext=system_u:system_r:realmd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:systemd_systemctl_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1350277585.224:370): arch=x86_64 syscall=execve success=yes exit=0 a0=14433d0 a1=14447b0 a2=1254500 a3=7fff1747c4c0 items=0 ppid=3242 pid=3331 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemctl exe=/usr/bin/systemctl subj=system_u:system_r:realmd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: systemctl,realmd_t,systemd_systemctl_exec_t,file,execute
:
:audit2allow
:
:#============= realmd_t ==============
:allow realmd_t systemd_systemctl_exec_t:file { read execute open execute_no_trans };
:
:audit2allow -R
:
:#============= realmd_t ==============
:allow realmd_t systemd_systemctl_exec_t:file { read execute open execute_no_trans };
:
Comment 1 Stef Walter 2012-10-15 01:08:34 EDT
Created attachment 627188 [details]
File: type
Comment 2 Stef Walter 2012-10-15 01:08:36 EDT
Created attachment 627189 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-15 04:45:53 EDT
*** Bug 866315 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2012-10-15 04:46:14 EDT
*** Bug 866316 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Grepl 2012-10-15 04:46:52 EDT
Fixed in selinux-policy-3.11.1-39.fc18.noarch
Comment 6 Fedora Update System 2012-10-23 16:34:42 EDT
selinux-policy-3.11.1-43.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-43.fc18
Comment 7 Fedora Update System 2012-10-26 11:37:39 EDT
selinux-policy-3.11.1-46.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-46.fc18
Comment 8 Fedora Update System 2012-10-26 15:27:07 EDT
Package selinux-policy-3.11.1-46.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-46.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16862/selinux-policy-3.11.1-46.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-12-20 09:59:58 EST
selinux-policy-3.11.1-46.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.