Bug 866318 - SELinux is preventing /usr/bin/systemctl from 'read' accesses on the lnk_file root.
SELinux is preventing /usr/bin/systemctl from 'read' accesses on the lnk_file...
Status: CLOSED DUPLICATE of bug 866316
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:7dba27a3fa4b5daa998e5ee249f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 01:11 EDT by Stef Walter
Modified: 2012-10-15 04:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 04:42:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-10-15 01:11 EDT, Stef Walter
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-10-15 01:11 EDT, Stef Walter
no flags Details

  None (edit)
Description Stef Walter 2012-10-15 01:11:30 EDT
Description of problem:
When running systemctl from realmd.

Additional info:
libreport version: 2.0.16
kernel:         3.6.1-1.fc18.x86_64

description:
:SELinux is preventing /usr/bin/systemctl from 'read' accesses on the lnk_file root.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that systemctl should be allowed read access on the root lnk_file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep systemctl /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:realmd_t:s0-s0:c0.c1023
:Target Context                system_u:system_r:init_t:s0
:Target Objects                root [ lnk_file ]
:Source                        systemctl
:Source Path                   /usr/bin/systemctl
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           systemd-194-1.fc18.x86_64
:Target RPM Packages           filesystem-3.1-2.fc18.x86_64
:Policy RPM                    selinux-policy-3.11.1-36.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.1-1.fc18.x86_64 #1 SMP Mon Oct
:                              8 17:19:09 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-10-15 01:06:25 EDT
:Last Seen                     2012-10-15 01:06:25 EDT
:Local ID                      35dc5133-0e00-45d8-9bf4-bcecf1430c68
:
:Raw Audit Messages
:type=AVC msg=audit(1350277585.311:374): avc:  denied  { read } for  pid=3337 comm="systemctl" name="root" dev="proc" ino=1191 scontext=system_u:system_r:realmd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0 tclass=lnk_file
:
:
:type=AVC msg=audit(1350277585.311:374): avc:  denied  { read } for  pid=3337 comm="systemctl" scontext=system_u:system_r:realmd_t:s0-s0:c0.c1023 tcontext=system_u:system_r:init_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1350277585.311:374): arch=x86_64 syscall=stat success=yes exit=0 a0=7fd68e3a7ac6 a1=7ffff3aa6df0 a2=7ffff3aa6df0 a3=2 items=0 ppid=3242 pid=3337 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=systemctl exe=/usr/bin/systemctl subj=system_u:system_r:realmd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: systemctl,realmd_t,init_t,lnk_file,read
:
:audit2allow
:
:#============= realmd_t ==============
:allow realmd_t init_t:file read;
:allow realmd_t init_t:lnk_file read;
:
:audit2allow -R
:
:#============= realmd_t ==============
:allow realmd_t init_t:file read;
:allow realmd_t init_t:lnk_file read;
:
Comment 1 Stef Walter 2012-10-15 01:11:33 EDT
Created attachment 627196 [details]
File: type
Comment 2 Stef Walter 2012-10-15 01:11:35 EDT
Created attachment 627197 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-10-15 04:42:50 EDT

*** This bug has been marked as a duplicate of bug 866316 ***

Note You need to log in before you can comment on or make changes to this bug.