Bug 866351 - Hyper-V guest cannot enter into single mode with the kernel option "single"
Hyper-V guest cannot enter into single mode with the kernel option "single"
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.9
Unspecified Linux
medium Severity medium
: rc
: 5.9
Assigned To: K. Y. Srinivasan
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 02:57 EDT by Bian Jinwei
Modified: 2012-10-29 07:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 07:14:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kys: needinfo-


Attachments (Terms of Use)
Hyper-V_guest_single_mode_hung (87.39 KB, image/png)
2012-10-15 02:59 EDT, Bian Jinwei
no flags Details

  None (edit)
Description Bian Jinwei 2012-10-15 02:57:52 EDT
Description of problem:
Install a Hyper-V guest rhel5.9 with kernel2.6.18-343.el5,when booting,edit the kernel option with "single" to enter into the single mode,when the guest begin to start,it will hang with a ouput,details in attachment.

Version-Release number of selected component (if applicable):
Hyper-V:6.1.7600.16385
Hyper-V guest:rhel5.9 with kernel2.6.18-343.el5

How reproducible:
100%

Steps to Reproduce:
1.Install a Hyper-V guest with kernel 2.6.18-343.el5
2.when booting edit the kernel with the single mode option "single"
3.boot with the single mode option
  
Actual results:
It will hang with a series of output

Expected results:
with the single option can enter into the single mode on Hyper-V guest

Additional info:
this issue existed on rhel5.9 with kernel2.6.18-333.el5,so this issue not related with pv drivers.
Comment 1 Bian Jinwei 2012-10-15 02:59:08 EDT
Created attachment 627217 [details]
Hyper-V_guest_single_mode_hung
Comment 2 Ronen Hod 2012-10-22 03:18:35 EDT
Probably a Hyper-V (hypervisor) bug.
KY, Can you please confirm it, and we will close this RHEL bug
Comment 3 K. Y. Srinivasan 2012-10-22 09:47:52 EDT
I will let Hashir (our test lead) comment on this. Hashir, it looks like the problem is there in the emulated mode of RHEL 5.9 on our platform and so this is not a PV driver issue (if we can verify this). We would need to potentially file a bug against the hypervisor. Please confirm.

Note You need to log in before you can comment on or make changes to this bug.