Bug 866372 - FormatSetupError: invalid device specification
FormatSetupError: invalid device specification
Status: CLOSED DUPLICATE of bug 865247
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:df19160bac314502742d95a311e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 04:40 EDT by Vitezslav Humpa
Modified: 2013-01-10 01:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 16:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (330.43 KB, text/plain)
2012-10-15 04:40 EDT, Vitezslav Humpa
no flags Details
File: product (24 bytes, text/plain)
2012-10-15 04:40 EDT, Vitezslav Humpa
no flags Details
File: type (9 bytes, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: storage.log (122.43 KB, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: version (3 bytes, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: environ (1022 bytes, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: anaconda.log (24.27 KB, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: syslog (103.96 KB, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: packaging.log (1.87 KB, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: cmdline_file (295 bytes, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: release (58 bytes, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details
File: program.log (48.81 KB, text/plain)
2012-10-15 04:41 EDT, Vitezslav Humpa
no flags Details

  None (edit)
Description Vitezslav Humpa 2012-10-15 04:40:48 EDT
Description of problem:
Anaconda crashed on typing in a password for an encrypted LUKS LVM in the 'Manual Partitioning' screen.

RHEL7...1012 through RH PXE


Version-Release number of selected component:
anaconda-18.16

Additional info:
libreport version: 2.0.16
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.0-0.28.el7.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.16 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/__init__.py", line 342, in setup
:    raise FormatSetupError("invalid device specification")
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/luks.py", line 168, in setup
:    DeviceFormat.setup(self, *args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1959, in on_unlock_clicked
:    device.format.setup()
:FormatSetupError: invalid device specification
Comment 1 Vitezslav Humpa 2012-10-15 04:40:56 EDT
Created attachment 627246 [details]
File: anaconda-tb
Comment 2 Vitezslav Humpa 2012-10-15 04:40:59 EDT
Created attachment 627247 [details]
File: product
Comment 3 Vitezslav Humpa 2012-10-15 04:41:01 EDT
Created attachment 627248 [details]
File: type
Comment 4 Vitezslav Humpa 2012-10-15 04:41:04 EDT
Created attachment 627249 [details]
File: storage.log
Comment 5 Vitezslav Humpa 2012-10-15 04:41:06 EDT
Created attachment 627250 [details]
File: version
Comment 6 Vitezslav Humpa 2012-10-15 04:41:08 EDT
Created attachment 627251 [details]
File: environ
Comment 7 Vitezslav Humpa 2012-10-15 04:41:11 EDT
Created attachment 627252 [details]
File: anaconda.log
Comment 8 Vitezslav Humpa 2012-10-15 04:41:13 EDT
Created attachment 627253 [details]
File: syslog
Comment 9 Vitezslav Humpa 2012-10-15 04:41:15 EDT
Created attachment 627254 [details]
File: hashmarkername
Comment 10 Vitezslav Humpa 2012-10-15 04:41:17 EDT
Created attachment 627255 [details]
File: packaging.log
Comment 11 Vitezslav Humpa 2012-10-15 04:41:19 EDT
Created attachment 627256 [details]
File: cmdline_file
Comment 12 Vitezslav Humpa 2012-10-15 04:41:21 EDT
Created attachment 627257 [details]
File: release
Comment 13 Vitezslav Humpa 2012-10-15 04:41:23 EDT
Created attachment 627258 [details]
File: program.log
Comment 14 Jesse Keating 2012-10-15 16:52:05 EDT
Lets track this by way of Fedora.

*** This bug has been marked as a duplicate of bug 865247 ***

Note You need to log in before you can comment on or make changes to this bug.