This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 866412 - Samba winbind doesn't return "Domain Local" groups
Samba winbind doesn't return "Domain Local" groups
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: samba (Show other bugs)
6.2
x86_64 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Andreas Schneider
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 06:06 EDT by john
Modified: 2013-02-21 03:45 EST (History)
3 users (show)

See Also:
Fixed In Version: samba-3.6.8-139.el6
Doc Type: Bug Fix
Doc Text:
Cause: A bug in winbind has been fixed which changed the behaviour of resolving groups. Consequence: A bugfix changed the behaviour of resolving domain local groups and winbind couldn't find them. Fix: We restored the original behaviour resolving the domain local groups of our own domain. Result: The id command resolves domain local groups of or own domain correctly again.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:45:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 9100 None None None 2012-10-15 06:06:01 EDT

  None (edit)
Description john 2012-10-15 06:06:01 EDT
Description of problem:
winbind doesn't return "Domain Local" groups from Windows 2008 Active Directory 

Version-Release number of selected component (if applicable):3.5.10-114


How reproducible: Install and configure Samba 3.5.10-114 with idmap backend as  "AD"


Steps to Reproduce:
1. Create and join the AD User to a  "Global group" and a "Domain Local group"
2. the "id <AD User>" command displays both Global group and Domain Local group membership
3. After successfull login of AD User to a RHEL system, logout the AD User
4. After approx 5 mins, the "id <AD User>" command displays only Global group membership.
  
Actual results: Installing and configuring Samba 3.5.18 resolves the issue.


Expected results: 

Additional info: Do we have any fixes from Red Hat to resolve this issue specific to Samba 3.5.10--14
Comment 2 Andreas Schneider 2012-10-15 07:59:40 EDT
This is https://bugzilla.samba.org/show_bug.cgi?id=9052 and has already been fixed for 6.4 due to the rebase.

The patch can be applied on 3.5.10 too.
Comment 8 errata-xmlrpc 2013-02-21 03:45:32 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0338.html

Note You need to log in before you can comment on or make changes to this bug.