Bug 866425 - segfault when adding device
segfault when adding device
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-bluetooth (Show other bugs)
7.0
All Linux
unspecified Severity high
: beta
: 7.0
Assigned To: Bastien Nocera
Desktop QE
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 06:48 EDT by Vladimir Benes
Modified: 2014-06-13 06:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:41:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb backtrace (20.51 KB, text/plain)
2012-10-16 05:20 EDT, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2012-10-15 06:48:42 EDT
Description of problem:
when I want to add my bluetooth headset I get segfault all the time

Version-Release number of selected component (if applicable):
gnome-bluetooth-3.6.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.start /usr/bin/bluetooth-wizard
2.add headphone device

  
Actual results:
segfault

Expected results:
device successfully added

Additional info:
backtrace attached
Comment 1 Vladimir Benes 2012-10-15 07:01:32 EDT
hmm strange.. after I failed to find previously written backtrace I cannot reproduce anymore.. closing now.. will reopen if it occurs again (suspend/rfkill, etc)

-> CLOSED
Comment 2 Vladimir Benes 2012-10-16 05:17:13 EDT
I've finally managed to reproduce.. it's crashing again now. I suspect something like this:

0. suspend/resume (maybe several times)
1. suspend
2. dock 
3. resume
4. add bluetooth device via wizard
Comment 3 Vladimir Benes 2012-10-16 05:20:01 EDT
Created attachment 628056 [details]
gdb backtrace
Comment 4 Bastien Nocera 2012-10-16 08:17:19 EDT
That's not really useful. You gave me a backtrace, but how do I know where it crashed if you remove it from the backtrace?
Comment 5 Martin Simon 2012-10-17 04:19:07 EDT
I have the same problem. No need to suspend/resume, I don't do it. My reproducer:

1. Start bluetooth-wizard
2. Wait a sec until bluetooth device is found
3. Click to the device you want connect to

Actual result:
Segmentation fault

Expected result:
Go next in wizard..
Comment 6 Martin Simon 2012-10-17 04:52:54 EDT
Few more information:

The situation with segfault request to click to searched up bluetooth device before the wizard has all information - there is only MAC address, no device name yet. Clicking on that device causes segfault as reported above.

If I wait until the name of device is shown, everything goes fine.
Comment 7 Bastien Nocera 2012-10-29 13:25:31 EDT
Fixed upstream, see bug 869083 for a work-around.
Comment 8 Vladimir Benes 2013-01-16 08:49:34 EST
no crashes any more, MAC can be clicked but continue button is greyed out until device name is obtained.
-> VERIFIED
Comment 9 Ludek Smid 2014-06-13 06:41:48 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.