Bug 866464 - The sync-ui-gtk executable is missing in syncevolution-gtk-1.3-1
The sync-ui-gtk executable is missing in syncevolution-gtk-1.3-1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: syncevolution (Show other bugs)
17
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 08:23 EDT by Bahtiar `kalkin` Gadimov
Modified: 2012-12-10 20:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 20:22:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from strace (4.90 KB, text/plain)
2012-10-19 09:13 EDT, Eric Berndt
no flags Details

  None (edit)
Description Bahtiar `kalkin` Gadimov 2012-10-15 08:23:10 EDT
Description of problem:

I can't use syncevolution-gtk any more because, /usr/bin/sync-ui-gtk is missing.

Version-Release number of selected component (if applicable):

1.3.1.fc17

How reproducible: always!

Steps to Reproduce:
1. Install syncevolution-gtk.
2. Try to run it. You will get an error that sync-ui-gtk can't be ran
  
Additional info:

I downgraded syncevolution and syncevolution-gtk to 1.2. The syncevolution-gtk version 1.2 provides the executable sync-ui-gtk. But it doesn't work. My assumption is that the version 1.3 changed the config/save data definitions so the version 1.2 can't work with the updated 1.3 config/save data. I could be completly wrong with my assumption, but this is the simplest explanation why the downgrade doesn't work.

There is another bug open for syncevolution-gtk which i can reproduce but i'm not sure if they're related https://bugzilla.redhat.com/show_bug.cgi?id=861720
Comment 1 Peter Robinson 2012-10-16 04:50:20 EDT
It's now just /usr/bin/sync-ui because we dropped the meego option. 

rpm -ql syncevolution-gtk
/usr/bin/sync-ui
/usr/share/applications/sync.desktop
Comment 2 Bahtiar `kalkin` Gadimov 2012-10-16 08:28:28 EDT
Meego? It still exists? :)

sync.desktop still contains Exec=sync-ui-gtk and sync-ui can't be run, because it throws the error which is mentioned in the bug 861720
Comment 3 Bahtiar `kalkin` Gadimov 2012-10-16 08:34:00 EDT
I have to correct my self. I'm not sure if the bug 861720 is the same as this error which i get when i try to run sync-ui:

(sync-ui:7003): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Comment 4 Eric Berndt 2012-10-19 09:13:32 EDT
Created attachment 630023 [details]
output from strace
Comment 5 Eric Berndt 2012-10-19 09:15:04 EDT
I get same error as posted above and haven't found any result to solve the problem. Downgrading to 1.2 doesn't work for me cause of dependencies, so i can't try if it works with the older version.
Comment 6 Fedora Update System 2012-10-20 07:25:29 EDT
syncevolution-1.3.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/syncevolution-1.3.1-2.fc17
Comment 7 Fedora Update System 2012-10-20 07:26:03 EDT
syncevolution-1.3.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/syncevolution-1.3.1-2.fc18
Comment 8 Fedora Update System 2012-10-21 01:59:24 EDT
Package syncevolution-1.3.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing syncevolution-1.3.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16562/syncevolution-1.3.1-2.fc18
then log in and leave karma (feedback).
Comment 9 Eric Berndt 2012-10-21 04:06:25 EDT
I just installed syncevolution-1.3.1-2.fc17 and all nessessary packages but it still does not work. While starting the gui only the error message that sync-ui-gtk does not exist don't appear any longer, but nothing happens.
Starting sync-ui from terminal still results my posted message with strace command.
Comment 10 Eric Berndt 2012-10-21 05:11:05 EDT
Installed kernel version is 3.5.1-1.fc17.x86_64. I haven't updated to 3.6.2 cause of kmod-staging for the kernel is missing yet and i need it for my wlan stick.
Comment 11 thomas.michel 2012-10-29 16:49:55 EDT
I have exactly the same error when starting sync-ui with the version from updates-testing (Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported)
Comment 12 Bahtiar `kalkin` Gadimov 2012-11-08 04:14:15 EST
So what is the status on this bug? It's still doesn't work, and this is the only solution to keep multiple devices synced.
Comment 13 Peter Robinson 2012-11-08 04:23:59 EST
(In reply to comment #12)
> So what is the status on this bug? It's still doesn't work, and this is the
> only solution to keep multiple devices synced.

I've not had time to investigate this further. Patches are welcome
Comment 14 Eric Berndt 2012-11-08 13:48:56 EST
i have downgraded to version 1.2.1-1.fc17.x86_64 and everything is working :))

in my yum.conf syncevolution is excluded for update
Comment 15 Fedora Update System 2012-12-01 10:50:44 EST
syncevolution-1.3.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/syncevolution-1.3.2-1.fc17
Comment 16 Eric Berndt 2012-12-03 00:22:47 EST
Just tried new version from testing repo but still get same error. Therefore i'm back on 1.2 again.
Comment 17 Peter Robinson 2012-12-03 04:00:53 EST
(In reply to comment #16)
> Just tried new version from testing repo but still get same error. Therefore
> i'm back on 1.2 again.

What same error? Please put the exact details of this (screen shots or whatever) because you've listed at least two errors above.

I tested this all as much as I could before I pushed the update. I no longer have a device to test with but a clean install of the package allowed me to run the UI from the gnome3 menu without issue. 

The sync-ui-gtk no longer exists, the .desktop file no longer contains incorrect naming. There were also old deps causing it to be linked against gtk2 rather than gtk3 and they are fixed as well.
Comment 18 Eric Berndt 2012-12-03 10:30:30 EST
Ok Peter...it works now.. i made a mistake after updating the version...thanks
Comment 19 Fedora Update System 2012-12-10 20:22:28 EST
syncevolution-1.3.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.