Bug 866479 - [intel drm/kms] Some artifacts are seen when scrolling
[intel drm/kms] Some artifacts are seen when scrolling
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 09:21 EDT by antonio montagnani
Modified: 2012-10-18 10:52 EDT (History)
14 users (show)

See Also:
Fixed In Version: kernel-3.6.2-4.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-18 10:52:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example of artifact (55.93 KB, image/png)
2012-10-15 09:21 EDT, antonio montagnani
no flags Details
file di log di yum (132.29 KB, text/plain)
2012-10-15 09:48 EDT, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2012-10-15 09:21:08 EDT
Created attachment 627415 [details]
example of artifact

Description of problem:
some artifacts are seen

Version-Release number of selected component (if applicable):
1:4.8.2-7.fc17

How reproducible:

always
Steps to Reproduce:
1.
2.
3.
  
Actual results:
some artifacts are seen when scrolling pages in any program

Expected results:
no artifact

Additional info:
Comment 1 Rex Dieter 2012-10-15 09:28:01 EDT
Usually indicative of video driver issues.

What video hardware/driver are you using?
Comment 2 antonio montagnani 2012-10-15 09:33:07 EDT
intel 915
Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)

But it happened suddenly, I would say since yesterday
Comment 3 Rex Dieter 2012-10-15 09:37:43 EDT
something updated recently ?

/var/log/yum.log ?

Other suspects include
* browser used
* anything font/cairo-related
* video drivers (kernel/xorg-x11-drv-intel)
Comment 4 Kevin Kofler 2012-10-15 09:38:19 EDT
Maybe due to the kernel update?

I'm reassigning it to xorg-x11-drv-intel in any case, it might be the mesa or kernel portions of the driver, but it's almost certainly a driver issue.
Comment 5 antonio montagnani 2012-10-15 09:48:48 EDT
Created attachment 627446 [details]
file di log di yum
Comment 6 antonio montagnani 2012-10-15 09:50:06 EDT
rebooted with a previous kernel, not experiencing any issue but maybe it takes some time, as also with new kernel I see artifacts after some time of operation
Comment 7 Kevin Kofler 2012-10-15 09:57:46 EDT
So everything points to a kernel bug.
Comment 8 antonio montagnani 2012-10-15 10:28:22 EDT
an additional info.

I started to note some problems during scrolling of pages containing images (online newspaper, facebook): the image started as a blank box than after scrolling appeared. But after some time time of operation I noted artifacts as in the attached image
Comment 9 Josh Boyer 2012-10-15 10:45:13 EDT
(In reply to comment #7)
> So everything points to a kernel bug.

Don't reassign video kernel bugs to the kernel component.  The same people work on them and it's much easier for them to find them when filed against xorg.
Comment 10 antonio montagnani 2012-10-15 11:21:59 EDT
after two hours of operation, no artifacts are seen using the previous kernel (3.5.6-1.fc17.i686.PAE).
Comment 11 antonio montagnani 2012-10-18 03:18:55 EDT
running on 3.6.2-4.fc17.i686.PAE, seems that bug has been solved
Comment 12 antonio montagnani 2012-10-18 05:56:07 EDT
I confirm that bug is solved, I do not seen any artifacts after 3 hours of operation on my laptop
Comment 13 Kevin Kofler 2012-10-18 10:52:08 EDT
Looks like kernel-3.6.2-4.fc17 is already queued for stable, closing.

Note You need to log in before you can comment on or make changes to this bug.