This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 866481 - lvcreate with allocation=0 fails, which virt-manager does by default
lvcreate with allocation=0 fails, which virt-manager does by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-15 09:25 EDT by Petr Schindler
Modified: 2012-12-13 11:59 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 14:33:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Schindler 2012-10-15 09:25:54 EDT
Description of problem:
When I want to create new storage volume in my pool (which is LVM volume groups) the following error occurs and no volume is created (creating of the storage volume on filesystem works fine):


Error creating vol: internal error Child process (/usr/sbin/lvchange -aln vg_data/newlv) unexpected exit status 5:   One or more specified logical volume(s) not found.


Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 96, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/createvol.py", line 248, in _async_vol_create
    self.vol.install(meter=meter)
  File "/usr/lib/python2.7/site-packages/virtinst/Storage.py", line 1213, in install
    vol = self.pool.createXML(xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 2262, in createXML
    if ret is None:raise libvirtError('virStorageVolCreateXML() failed', pool=self)
libvirtError: internal error Child process (/usr/sbin/lvchange -aln vg_data/newlv) unexpected exit status 5:   One or more specified logical volume(s) not found.

Version-Release number of selected component (if applicable):
virt-manager-0.9.4-1.fc18.1.noarch

How reproducible:
100%

Steps to Reproduce:
1. Try to create a new storage volume in lvm volume group pool
  
Actual results:
Error message is shown and no volume is created

Expected results:
New volume should be created

Additional info:
I propose this bug as final blocker. User won't be able to create a new virtual machine (with LVM vg pool), so he/she won't be able to host the system. Violated criterion is: "The release must be able host virtual guest instances of the same release, using Fedora's current preferred virtualization technology"
Comment 1 Cole Robinson 2012-10-16 20:43:37 EDT
I wouldn't call this a blocked: while LVM is the preferred and default storage for the host machine, most people don't use it to provision virt storage on the host, and it's not the default virt-manager config.

Also it's quite easy to work around: just set a non-zero 'allocation' in the UI.

The root issue here is that lvcreate doesn't like allocation=0 which is what virt-manager obviously does by default. I think this is really a libvirt issue, it can easily turn 0 into a minimal value to make lvcreate happy and still give API users the closest approximation to what they requested.

I've sent a libvirt patch upstream that fixes this:
https://www.redhat.com/archives/libvir-list/2012-October/msg00857.html
Comment 2 Fedora Update System 2012-10-27 18:31:09 EDT
libvirt-0.10.2.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libvirt-0.10.2.1-1.fc18
Comment 3 Fedora Update System 2012-10-28 12:33:11 EDT
Package libvirt-0.10.2.1-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-0.10.2.1-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17097/libvirt-0.10.2.1-1.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-10-30 21:20:13 EDT
libvirt-0.10.2.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libvirt-0.10.2.1-2.fc18
Comment 5 Adam Williamson 2012-11-22 14:33:21 EST
The update was pushed stable, closing (Bodhi was broken for a while, this is me doing my Bodhi impersonation). Petr, do re-open if this is not actually fixed.
Comment 6 Eric Blake 2012-12-13 11:59:15 EST
*** Bug 872162 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.