Bug 866486 - Cannot update system via PackageKit-based apps in KDE with update checking enabled
Cannot update system via PackageKit-based apps in KDE with update checking en...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-10-15 09:36 EDT by Martin Krizek
Modified: 2012-11-01 15:05 EDT (History)
13 users (show)

See Also:
Fixed In Version: PackageKit-0.8.4-7.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-01 15:05:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pkmon output (141.66 KB, text/plain)
2012-10-24 07:01 EDT, Martin Krizek
no flags Details

  None (edit)
Description Martin Krizek 2012-10-15 09:36:28 EDT
Description of problem:
When selecting 'Apply' to install new updates, it goes back to the list of available packages.

Version-Release number of selected component (if applicable):
yum-3.4.3-45.fc18.noarch
PackageKit-0.8.4-3.fc18.x86_64
apper-0.8.0-0.7.20121002git.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run Apper
2. Go to Updates
3. Click Apply
  
Actual results:
Seems like the updates process is started but before downloading packages starts it goes back to the list of available updates.

Expected results:
Updates are installed.
Comment 1 Martin Krizek 2012-10-15 09:38:57 EDT
Proposing as a beta blocker per criterion: "The installed system must be able to download and install updates with yum and the default graphical package manager in all release-blocking desktops"
Comment 2 Adam Williamson 2012-10-15 11:47:31 EDT
Discussed at 2012-10-15 QA meeting acting as a blocker review meeting: http://meetbot.fedoraproject.org/fedora-meeting/2012-10-15/fedora-qa.2012-10-15-15.00.log.txt . Accepted as a blocker per criterion cited in comment #1.
Comment 3 Lukáš Tinkl 2012-10-15 12:07:16 EDT
Ok, going to try with the most recent snapshot
Comment 4 Lukáš Tinkl 2012-10-15 12:46:20 EDT
Pushed in git, can't build atm due to:

Error: Package: PackageKit-yum-0.8.4-4.fc19.i686 (build)
           Requires: yum >= 3.4.3-45
           Installing: yum-3.4.3-43.fc19.noarch (build)
               yum = 3.4.3-43.fc19
Error: Package: PackageKit-yum-0.8.4-4.fc19.i686 (build)
           Requires: yum >= 3.4.3-45
           Available: yum-3.4.3-43.fc19.noarch (build)
               yum = 3.4.3-43.fc19
Comment 5 Rex Dieter 2012-10-15 14:46:29 EDT
Hoping this build should help fix it:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4592340

(this one worked for me in 4 test tries, after various other attempts failed).

In short, it's a 20121002git snapshot rebuild minus an experimental systemd_inhibit patch.
Comment 6 Martin Krizek 2012-10-16 10:46:49 EDT
The build works for me.
Comment 7 Fedora Update System 2012-10-16 11:18:13 EDT
apper-0.8.0-0.8.20121002git.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/apper-0.8.0-0.8.20121002git.fc18
Comment 8 Fedora Update System 2012-10-16 13:44:18 EDT
Package apper-0.8.0-0.8.20121002git.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apper-0.8.0-0.8.20121002git.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16233/apper-0.8.0-0.8.20121002git.fc18
then log in and leave karma (feedback).
Comment 9 Adam Williamson 2012-10-16 18:33:57 EDT
setting VERIFIED per martix's test above (same build).
Comment 10 Martin Krizek 2012-10-22 05:29:49 EDT
I hit this again with apper-0.8.0-0.8.20121002git.fc18 on F18 Beta TC6
Comment 11 Adam Williamson 2012-10-22 20:34:03 EDT
this seems a bit confusing...
Comment 12 Kamil Páral 2012-10-23 09:05:02 EDT
Martin says the same build worked for him in TC4 and doesn't work in TC6. Setting back to ASSIGNED. Rex, tell us what logs Martin can provide to help you debug this issue.
Comment 13 Rex Dieter 2012-10-23 09:14:23 EDT
For starters,

* output from 'pkmon'

* and see if 'pkcon update' has similar issues (or not)
Comment 14 Martin Krizek 2012-10-24 07:01:17 EDT
Created attachment 632691 [details]
pkmon output
Comment 15 Martin Krizek 2012-10-24 07:02:57 EDT
So I tested it a bit more and found out what caused the confusion with the build working in TC4 and not in TC6. According to my testing, updating only works when 'Check for updates' is set to Never. So on default clean install it doesn't work. It affects pkcon as well. pkmon output attached.
Comment 16 Adam Williamson 2012-10-24 20:17:06 EDT
I concur with mkrizek. I did a DVD install of TC6 and tried installing updates with Apper. As described in this bug, it just cycles back to the 'available updates' screen. After setting check for updates to 'never' and trying again, it has hit the 'Downloading packages' step, which it didn't before, so it seems to be working.
Comment 17 Kevin Kofler 2012-10-24 21:05:08 EDT
Unfortunately, never checking for updates is NOT an acceptable workaround.
Comment 18 Adam Williamson 2012-10-24 21:53:26 EDT
of course not, but it seems like it's useful for diagnosis purposes. I was just providing confirmation of mkrizek's diagnosis of the problem.
Comment 19 Rex Dieter 2012-10-26 12:56:06 EDT
So, one big complicating factor here is that subsequent commits to apper upstream have up'd the PackageKit requirement to 0.8.5
:(
Comment 20 Rex Dieter 2012-10-26 13:31:11 EDT
I poked dannti on irc today, he said he'd try to take a look at the current state of things over the weekend.
Comment 21 Adam Williamson 2012-10-26 13:37:44 EDT
Thanks. Go/No-Go for Beta is on 11-01, so we really need this pretty soon :)
Comment 22 Jaroslav Reznik 2012-10-30 10:44:08 EDT
Rex,
any news? One possibility ltinkl proposed today is to use GPK in case we would need it this week and there will be no known Apper solution (for Beta).
Comment 23 Lukáš Tinkl 2012-10-30 12:16:56 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=4639708 (test build)
Comment 24 Fedora Update System 2012-10-30 14:27:46 EDT
PackageKit-0.8.4-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/PackageKit-0.8.4-5.fc18
Comment 25 Adam Williamson 2012-10-30 18:59:03 EDT
0.8.4-6 (which was submitted later) does not appear to fix this for me. I built a KDE live image for testing with that version of PK included. I installed and immediately attempted to update. It behaved as reported in this bug; almost no change at all. It found the packages for update, I selected them all and hit Apply, it did a few steps and then cycled right back to the list of available updates. After changing the configuration to check for updates from 'Daily' to 'Never' and trying again, it worked.

The only difference is that at the time it failed, a crash in packagekitd was reported by abrt. According to abrt that crash was https://bugzilla.redhat.com/show_bug.cgi?id=871032 . But that bug was filed with an older PackageKit, so it may be coincidental. So far as I can tell the main behaviour here has not changed.
Comment 26 Adam Williamson 2012-10-30 21:27:42 EDT
dantti said he can reproduce this with gnome-packagekit, but I can't reproduce it on a GNOME install. I guess the difference is the KDE update checker - remember, this bug doesn't happen if you disable checking for updates. I'll check that I can reproduce it using gnome-packagekit in KDE.
Comment 27 Adam Williamson 2012-10-30 21:54:09 EDT
OK, I confirm I can reproduce the bug using gnome-packagekit (gpk-update-viewer) within KDE - but not with a GNOME install. So the bug is not apper-specific, but it *is* KDE specific. Definitely sounds like it's to do with the KDE update checking mechanism somehow.

Re-assigning bug to PackageKit for now and adjusting summary.
Comment 28 Lukáš Tinkl 2012-10-31 06:33:41 EDT
This is weird, what KDE code could gpk-update-viewer use when running in a KDE session... I can't think of any. Can you try to reproduce the behavior of gpk-update-viewer in KDE with apper uninstalled?
Comment 29 Martin Krizek 2012-10-31 07:56:28 EDT
So according to my testing in KDE, gpk-update-viewer is affected by this bug *only* when apper is installed (I had to reboot after uninstalling apper).
Comment 30 Lukáš Tinkl 2012-10-31 08:46:39 EDT
The only thing I could come up with that gpk-update-viewer and apper have in common is polkit-kde (when running under KDE). Just for completeness, have you tried running apper inside Gnome Shell?
Comment 31 Martin Krizek 2012-10-31 09:06:16 EDT
Running Apper inside Gnome Shell works.
Comment 32 Jaroslav Reznik 2012-10-31 09:14:24 EDT
Could you retry with Gnome polkit in KDE?
Comment 33 Richard Hughes 2012-10-31 10:07:11 EDT
I've also built PackageKit-0.8.4-7.fc18 with some more fixes backported from upstream. It could be the UpdatesChanged fix would fix the apper background process somehow, although I'm not familiar with how apper works internally.
Comment 34 Jaroslav Reznik 2012-10-31 11:49:21 EDT
(In reply to comment #33)
> I've also built PackageKit-0.8.4-7.fc18 with some more fixes backported from
> upstream. It could be the UpdatesChanged fix would fix the apper background
> process somehow, although I'm not familiar with how apper works internally.

Great, I was able to update using PackageKit-0.8.4-7.fc18!
Comment 35 Lukáš Tinkl 2012-10-31 12:54:56 EDT
I can too confirm that with PackageKit-0.8.4-7.fc18, apper is back in business, yay!
Comment 36 Fedora Update System 2012-10-31 14:13:51 EDT
Package PackageKit-0.8.4-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-0.8.4-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17371/PackageKit-0.8.4-7.fc18
then log in and leave karma (feedback).
Comment 37 Adam Williamson 2012-10-31 21:01:02 EDT
Yup, works for me too. karma changed.
Comment 38 Martin Krizek 2012-11-01 04:25:33 EDT
Confirming, works for me as well.
Comment 39 Tim Flink 2012-11-01 15:05:19 EDT
Closing this because the update from c#36 has been pushed to stable after the fix was verified.

Note You need to log in before you can comment on or make changes to this bug.