Bug 866497 - missing NULL check in audit_log_link_denied
missing NULL check in audit_log_link_denied
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 09:54 EDT by Tom Horsley
Modified: 2013-01-02 12:17 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 12:17:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
photo of oops that appeared on the screen (473.36 KB, image/jpeg)
2012-10-15 09:54 EDT, Tom Horsley
no flags Details

  None (edit)
Description Tom Horsley 2012-10-15 09:54:09 EDT
Created attachment 627448 [details]
photo of oops that appeared on the screen

Description of problem:

I installed the latest updates this morning and rebooted to get the 3.6.1 kernel loaded. After using the system for a bit, I got the kernel OOPS I will attach a photo of.

The oops was very sudden, and when it happened, I was trying to connect an android device to my local subnet created via hostapd on my f17 desktop. I mention that since I see dhcpd mentioned in the OOPS.

I also see audit mentioned in the OOPS, and I was running with the audit=0 kernel command line option. When rebooting, I removed that and enabled the auditd service, so I'll see if I get another oops with audit running.


Version-Release number of selected component (if applicable):
kernel-3.6.1-1.fc17.x86_64

How reproducible:
Just once so far.

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
sudden oops

Expected results:
sustem keeps working

Additional info:
Comment 1 Dave Jones 2012-10-17 15:22:42 EDT
this should be fixed upstream in commit d1c7d97ad58836affde6e39980b96527510b572e
I'll point it out for the stable maintainers.
Comment 2 Tom Horsley 2012-10-17 15:40:01 EDT
With audit enabled, the oops has not happened again, so it does indeed sound like a missing NULL pointer check could do it.
Comment 3 Josh Boyer 2013-01-02 12:17:29 EST
This was backported to 3.6.3 with stable commit 724373bd489eb02e1999e2714fcc00658e081a9b

Note You need to log in before you can comment on or make changes to this bug.