Bug 866531 - Process with group tasks and parallel gateways fails to finish with EE6 bundle
Process with group tasks and parallel gateways fails to finish with EE6 bundle
Status: CLOSED NOTABUG
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5, jBPM Console (Show other bugs)
BRMS 5.3.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Maciej Swiderski
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 11:00 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 06:53:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test repository (398.81 KB, application/xml)
2012-10-15 11:00 EDT, Zuzana Krejčová
no flags Details
server log (80.35 KB, text/plain)
2012-10-18 08:17 EDT, Zuzana Krejčová
no flags Details
Server log from a test run (82.66 KB, text/x-log)
2012-10-19 06:24 EDT, Maciej Swiderski
no flags Details
configuration set (persistence, standalon and web.xml) (6.18 KB, application/zip)
2012-10-22 10:37 EDT, Maciej Swiderski
no flags Details

  None (edit)
Description Zuzana Krejčová 2012-10-15 11:00:11 EDT
Created attachment 627510 [details]
test repository

Description of problem:

My environment is BRMS 5.3.1 ER3 ee6 deployable bundle, EAP 6.0, PostgreSQL 9.1.6.

I have a simple process with a sequence like this: parallel gateway -> 2 user tasks assigned to group -> parallel gateway. When running the process, it never gets past the second gateway. Looking into the database, I can see that both tasks were finished, the diagram shows the marker on the second gateway, but that's where it ends, it stops at the gateway.
I encountered this in the Console (not sure yet if the problem is only there).

The problem seems to be exclusively with multiple group tasks going to one parallel gateway. I have not seen this with script tasks nor with human tasks assigned to user. XOR gateway also does not cause this.


Version-Release number of selected component (if applicable):
I have seen this first in BRMS 5.3.1 ER1, could not test it sooner than ER3.


Steps to Reproduce:

I'm using group called user.
1. get the provided repo and import it to Guvnor
2. build the package and log into Console
3. start the test process (called test), go to group tasks, claim both and complete them.
4. go to process overview and look at the instance diagram - refresh the process if you want.

  
Actual results:
The instance is still running, marker is on the second gateway.


Expected results:
The instance was finished.


Additional info:
The repository export contains 2 more processes - scriptTaskGateway and onegrouptask. 
The first one shows that if you use script tasks instead of group user tasks, it works.
The second shows that it also works well if there is only one group task and the other is script task.
Comment 1 Zuzana Krejčová 2012-10-18 08:17:33 EDT
Created attachment 629335 [details]
server log
Comment 2 Zuzana Krejčová 2012-10-18 08:21:49 EDT
I also find this:
012-10-18 14:19:04,196 [FATAL] Uncaught Exception:
com.google.gwt.core.client.JavaScriptException:
(TypeError): this$static is undefined
fileName: http://localhost:8080/business-central/app/B158F233A31CCFA566C1AB4EC121B6BF.cache.html
lineNumber: 13267
    at Unknown.$fillInStackTrace_1(JsArrayString.java:42)
    at Unknown.$JavaScriptException(StackTraceCreator.java:366)
    at Unknown.caught_0(Exceptions.java:29)
    at Unknown.$update_8(AssignedTasksView.java:361)
    at Unknown.handleSuccessfulResponse_15(LoadTasksAction.java:77)
    at Unknown.onResponseReceived_5(AbstractRESTAction.java:78)
    at Unknown.$fireOnResponseReceived(Request.java:287)
    at Unknown.onReadyStateChange_0(RequestBuilder.java:393)
    at Unknown.anonymous(XMLHttpRequest.java:258)
    at Unknown.entry0(Impl.java:146)
    at Unknown.anonymous(Impl.java:56)
in the console, in messages, when I claim the group task. I am not sure if it's related though.
Comment 3 Maciej Swiderski 2012-10-19 06:23:08 EDT
Unfortunately I can't reproduce it with pattached repository on this bundle: http://jawa05.englab.brq.redhat.com/candidate/BRMS-5.3.1-ER3/brms-p-5.3.1.ER3-deployable-ee6.zip

Changes done to run it:
1. define postgresql module with jdbc driver
2. define data source for postgresql in standalone.xml
3. define brms security realm in standalone
4. define org.jboss.netty dependency in MANIFEST.MF for business-central-server.war and jbpm-human-task.war
5. configure persistence.xml for business-central-server.war and jbpm-human-task.war to use postgresql dialect

Attached is a server log file from single test of executing test process, as you can see script task was executed as soon as second task was completed and process instance has finished correctly.
Comment 4 Maciej Swiderski 2012-10-19 06:24:22 EDT
Created attachment 629928 [details]
Server log from a test run
Comment 5 Maciej Swiderski 2012-10-19 06:25:54 EDT
one more configuration that was done: register default user group callback implementation via web.xml of jbm-human-task.war
Comment 6 Zuzana Krejčová 2012-10-22 08:14:44 EDT
(In reply to comment #3)
> Changes done to run it:
> 1. define postgresql module with jdbc driver
> 2. define data source for postgresql in standalone.xml
> 3. define brms security realm in standalone
> 4. define org.jboss.netty dependency in MANIFEST.MF for
> business-central-server.war and jbpm-human-task.war
> 5. configure persistence.xml for business-central-server.war and
> jbpm-human-task.war to use postgresql dialect

Curious.
Could you send me/attach your persistence.xml files? Perhaps even the standalone.xml. Maybe I have something configured wrong, though it seems a bit unlikely with what it is doing..
Thanks.
Comment 7 Maciej Swiderski 2012-10-22 10:37:25 EDT
Created attachment 631579 [details]
configuration set (persistence, standalon and web.xml)
Comment 8 Zuzana Krejčová 2012-10-24 06:53:47 EDT
Misconfiguration, solved, closing. Thanks for the help, Maciej.

Note You need to log in before you can comment on or make changes to this bug.