Bug 866621 - RFE: Global proxy configuration
RFE: Global proxy configuration
Status: CLOSED DUPLICATE of bug 878548
Product: Pulp
Classification: Community
Component: rpm-support (Show other bugs)
2.0.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Sprint 42
Assigned To: Jay Dobies
Preethi Thomas
: Triaged
Depends On:
Blocks: katello-v2-pulp
  Show dependency treegraph
 
Reported: 2012-10-15 14:05 EDT by Justin Sherrill
Modified: 2012-11-27 15:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 15:39:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2012-10-15 14:05:23 EDT
In katello's use case all repositories that sync need to use the same proxy information.  If the user needs to change it we need to change it for all repos.  This is a bit cumbersome and error prone so it would be fantastic if we could just set a global default in server.conf instead of the global default being 'no proxy'.
Comment 1 Jay Dobies 2012-10-16 09:46:11 EDT
A plugin can have a conf file that Pulp will load and make accessible. We can store the info in the yum importer's conf file.
Comment 2 Jay Dobies 2012-11-27 15:39:58 EST
Fixed in 2.0 in a different bug, marking this one as a duplicate.

*** This bug has been marked as a duplicate of bug 878548 ***

Note You need to log in before you can comment on or make changes to this bug.