Bug 866636 - Anaconda configuration option failures
Anaconda configuration option failures
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 14:57 EDT by KitchM
Modified: 2012-10-15 16:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-15 15:38:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description KitchM 2012-10-15 14:57:43 EDT
Description of problem:
Anaconda fails to offer the ability to check available hardware devices to verify if they are recognized, configured properly and working.  Network was not offered on upgrade, and sound devices were never tested.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Run 17 network install
2.Use upgrade option
3.
  
Actual results:
Options not available

Expected results:
Should be able to check and configure

Additional info:
Comment 1 Chris Lumens 2012-10-15 15:38:52 EDT
It is not the installer's job to test your hardware for you, and networking is not necessarily needed to be brought up on updates - especially if you used preupgrade to do this.
Comment 2 KitchM 2012-10-15 16:03:20 EDT
I don't know what preupgrade is, but I do know this; during the regular installation routine, the user is given an option for configuring the network.  Further, it should be the responsibility of the installer software to make sure that the hardware is there.  Else, why install things like media players, usb drivers, or cd software.  Since there is no hardware configuration options given later, this is absolutely required for an OS to work correctly.

Note You need to log in before you can comment on or make changes to this bug.