Bug 866646 - Section 5.1 section 1 bogus kills
Section 5.1 section 1 bogus kills
Status: CLOSED CURRENTRELEASE
Product: CloudForms Common
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
1.1.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dan Macpherson
ecs-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 15:20 EDT by pgambard
Modified: 2012-12-10 16:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 16:50:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pgambard 2012-10-15 15:20:00 EDT
Description of problem:
The instructions for removal of katello contain bogus kill statements

Version-Release number of selected component (if applicable):
1.1

How reproducible:
very

Steps to Reproduce:
1. run katello-service stop
2. kill -9 `ps -aef | grep katello | grep -v grep | awk '{print $2}'`
3. kill -9 `ps -aef | grep delayed_job | grep -v grep | awk '{print $2}'`
  
Actual results:

[root@katello ~]# katello-service stop
Shutting down Katello services...
Stopping katello:
Stopping elasticsearch:                                    [  OK  ]
Stopping httpd:                                            [  OK  ]
Stopping Qpid AMQP daemon:                                 [  OK  ]
Stopping mongod:                                           [  OK  ]
Stopping httpd:                                            [FAILED]
Stopping tomcat6:                                          [  OK  ]
Done.
[root@katello ~]# kill -9 `ps -aef | grep katello | grep -v grep | awk '{print $2}'`
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
[root@katello ~]# kill -9 `ps -aef | grep delayed_job | grep -v grep | awk '{print $2}'`
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]

Expected results:
kill should return nothing instead of an error bombing out because it found no PID to kill or the kills in the document are unnessesary

Additional info:
Comment 2 Dan Macpherson 2012-10-18 14:27:10 EDT
I think they're unnecessary. Originally there wasn't a script to stop the katello services so you had to stop the processes manually.

I'll remove them from the documentation.
Comment 3 Dan Macpherson 2012-10-18 15:09:53 EDT
Removed. Changes will be available next time the guide has been brewed.
Comment 6 Lana Brindley 2012-11-18 21:37:27 EST
This documentation has now been dropped to translation ahead of publication. For any further issues, please open a new a bug.

LKB
Comment 7 Lana Brindley 2012-12-10 16:50:28 EST
This document is now publicly available on access.redhat.com. For any further issues, please raise a new bug.

LKB

Note You need to log in before you can comment on or make changes to this bug.