Bug 866672 - Fedora 18 Invalid status line from script wsgi.py seen when running ipa commands
Fedora 18 Invalid status line from script wsgi.py seen when running ipa commands
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mod_wsgi (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 16:32 EDT by Scott Poore
Modified: 2012-11-23 02:30 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 02:30:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Poore 2012-10-15 16:32:18 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Scott Poore 2012-10-15 16:39:46 EDT
Not sure what happened there...

Description of problem:

When running ipa commands, I'm seeing errors like this:

2012-10-09T20:58:09Z ERROR Cannot connect to the server due to generic error: cannot connect to Gettext('any of the configured servers', domain='ipa', localedir=None): https://f18-2.testrelm.com/ipa/xml, https://f18-1.testrelm.com/ipa/xml

When I look at the httpd error_log on the server, I see this:

[Tue Oct 09 16:58:09.935833 2012] [core:error] [pid 9598] [client 192.168.122.182:49108] Invalid status line from script 'wsgi.py': Status, referer: https://f18-2.testrelm.com/ipa/xml

Version-Release number of selected component (if applicable):

[root@f18-1 ~]# rpm -q mod_wsgi
mod_wsgi-3.3-7.fc18.x86_64
[root@f18-1 ~]# rpm -q httpd 
httpd-2.4.2-23.fc18.x86_64
[root@f18-1 ~]# rpm -q freeipa-admintools freeipa-server
freeipa-admintools-3.0.0-2.fc18.x86_64
freeipa-server-3.0.0-2.fc18.x86_64


How reproducible:
sporadically but, I am seeing it many times today alone.

Steps to Reproduce:
1.  Install IPA Master
2.  Install IPA Replica
3.  Install IPA Client
4.  On Client:  ipa user-find
May need to run many times to see error.
  
Actual results:

ipa ERROR Cannot connect to the server due to generic error: cannot connect to Gettext('any of the configured servers', domain='ipa', localedir=None): https://f18-2.testrelm.com/ipa/xml, https://f18-1.testrelm.com/ipa/xml

And in /var/log/httpd/error_log on IPA server:

[Tue Oct 09 16:58:09.935833 2012] [core:error] [pid 9598] [client 192.168.122.182:49108] Invalid status line from script 'wsgi.py': Status, referer: https://f18-2.testrelm.com/ipa/xml
Expected results:

no errors

Additional info:
Comment 2 Jason Montleon 2012-10-15 17:53:16 EDT
I am seeing a similar error when trying to install a replica:

2012-10-15T21:05:58Z DEBUG stderr=Hostname: s02.ipa.montleon.intra
Realm: IPA.MONTLEON.INTRA
DNS Domain: ipa.montleon.intra
IPA Server: s02.ipa.montleon.intra
BaseDN: dc=ipa,dc=montleon,dc=intra
Domain ipa.montleon.intra is already configured in existing SSSD config, creating a new one.
The old /etc/sssd/sssd.conf is backed up and will be restored during uninstall.
Configured /etc/sssd/sssd.conf
trying https://s02.ipa.montleon.intra/ipa/xml
trying https://s01.ipa.montleon.intra/ipa/xml
Cannot connect to the server due to generic error: cannot connect to Gettext('any of the configured servers', domain='ipa', localedir=None): https://s02.ipa.montleon.intra/ipa/xml, https://s01.ipa.montleon.intra/ipa/xml
Installation failed. Rolling back changes.
Removing Kerberos service principals from /etc/krb5.keytab
Disabling client Kerberos and LDAP configurations
Restoring client configuration files
nscd.service daemon is not installed, skip configuration
nslcd.service daemon is not installed, skip configuration
Client uninstall complete.

2012-10-15T21:05:58Z INFO   File "/usr/lib/python2.7/site-packages/ipaserver/install/installutils.py", line 614, in run_script
    return_value = main_function()

  File "/usr/sbin/ipa-replica-install", line 646, in main
    raise RuntimeError("Failed to configure the client")

2012-10-15T21:05:58Z INFO The ipa-replica-install command failed, exception: RuntimeError: Failed to configure the client
Comment 3 Rob Crittenden 2012-10-15 18:06:28 EDT
I enabled the dumpio module and it seems that this is the status that is being choked on:

[Mon Oct 15 17:53:01.600931 2012] [core:trace4] [pid 20131] util_script.c(522): [client 192.168.166.46:52966]   Status: 0 Continue, referer: https://test.example.com/ipa/xml

As a goof I upgraded to upstream mod_wsgi 3.4 and I no longer see this problem. I did some quick diffs between the two versions and some changes were made around the Continue/Reject code but I've yet to fully grok the changes. It looks like they are using real HTTP response codes now though, 200 instead of 0.
Comment 4 Matthias Runge 2012-10-16 02:27:10 EDT
alright, recently, I've built mod_wsgi-3.4, but would like to test it a bit more. Currently, it's done only on rawhide.
I would appreciate testing from you, too; if successful, I'd push it to f18, also.
Comment 5 Scott Poore 2012-10-16 09:04:09 EDT
Matthias,

Could you push  it to F18 rawhide too?  That's where I'm seeing the issue.  

Thanks,
Scott
Comment 6 Matthias Runge 2012-10-16 09:32:18 EDT
Rawhide is currently F19, F18 is F18 ;-)
Comment 7 Matthias Runge 2012-10-16 09:34:07 EDT
(In reply to comment #5)
> Could you push  it to F18 rawhide too?  That's where I'm seeing the issue.  
It's currently building. I'm merely away from keyboard, but I'll push it as soon as I can. OK?
Comment 8 Scott Poore 2012-10-16 09:40:36 EDT
Duh, that's right.  Shouldn't I have been able to see it from an F18 in the rawhide repo though?

[root@f18-1 ~]# yum --enablerepo=rawhide list mod_wsgi
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
mod_wsgi.x86_64                                   3.3-7.fc18                                    @fedora

Sure, just let me know when it's in F18 and I'll test it out.

Thanks,
Scott
Comment 9 Fedora Update System 2012-10-16 10:06:14 EDT
mod_wsgi-3.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mod_wsgi-3.4-1.fc18
Comment 10 Matthias Runge 2012-10-16 10:09:00 EDT
Scott,

usually, it takes about one day, until updates finally hit the mirrors. Safest bet is to follos the link from c#9 and do a yum localinstall on the rpm.

I'd really appreciate feedback,
Thanks, Matthias
Comment 11 Scott Poore 2012-10-16 11:26:11 EDT
Yep, that appears to fix the issue I was seeing.  I tried to reproduce for almost an hour with no luck.  Looks to fix that issue.  I think there's now another IPA issue but, that's for another ticket.  I'll leave karma.  

Thanks,
Scott
Comment 12 Scott Poore 2012-10-16 11:36:40 EDT
FYI, other ticket for new ipa issue seen here:

https://fedorahosted.org/freeipa/ticket/3186
Comment 13 Fedora Update System 2012-10-16 13:41:44 EDT
Package mod_wsgi-3.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mod_wsgi-3.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16222/mod_wsgi-3.4-1.fc18
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2012-10-17 03:26:42 EDT
mod_wsgi-3.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mod_wsgi-3.4-2.fc18
Comment 15 Martin Kosek 2012-10-17 03:55:13 EDT
Thanks Mathias, this fixed the invalid status line error for FreeIPA server in F18, giving karma+. However, there is still an issue when mod_wsgi Segfaults after httpd restart, but I will rather open a new bug for this (if it is not already opened).
Comment 16 Jason Montleon 2012-10-18 00:02:08 EDT
I was able to properly install a replica with 3.4-2, so it appears to have fixed my initial issue.
Comment 17 Fedora Update System 2012-11-14 02:27:34 EST
mod_wsgi-3.4-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mod_wsgi-3.4-4.fc18
Comment 18 Fedora Update System 2012-11-23 02:30:18 EST
mod_wsgi-3.4-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.