Bug 866707 - [abrt] blueman-1.23-2.fc17: DeviceList.py:332:SetAdapter:AttributeError: 'module' object has no attribute 'DBusServiceUnknownError'
[abrt] blueman-1.23-2.fc17: DeviceList.py:332:SetAdapter:AttributeError: 'mod...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
abrt_hash:e118b5db0b2c574808f28fefa73...
: HardwareEnablement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 19:08 EDT by Zahir Toufie
Modified: 2013-04-29 20:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: kernel 3.8.9-200.fc18 and bluez 4.101-6.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 729871
Environment:
Last Closed: 2013-04-29 20:28:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (654 bytes, text/plain)
2012-10-15 19:08 EDT, Zahir Toufie
no flags Details

  None (edit)
Description Zahir Toufie 2012-10-15 19:08:24 EDT
Description of problem:
I tried to pair my Acer Rechargeable Bluetooth Mouse with my Fedora x86_64 17 installation using blueman

Version-Release number of selected component:
blueman-1.23-2.fc17

Additional info:
libreport version: 2.0.14
abrt_version:   2.0.13
cmdline:        /usr/bin/python /usr/bin/blueman-assistant --device=00:10:C6:54:C5:8D
kernel:         3.5.5-2.fc17.x86_64

backtrace:
:DeviceList.py:332:SetAdapter:AttributeError: 'module' object has no attribute 'DBusServiceUnknownError'
:
:Traceback (most recent call last):
:  File "/usr/bin/blueman-assistant", line 399, in <module>
:    Assistant()
:  File "/usr/bin/blueman-assistant", line 119, in __init__
:    self.dev_widget = DeviceSelectorWidget()
:  File "/usr/lib/python2.7/site-packages/blueman/gui/DeviceSelectorWidget.py", line 38, in __init__
:    self.List = devlist = DeviceSelectorList(adapter)
:  File "/usr/lib/python2.7/site-packages/blueman/gui/DeviceSelectorList.py", line 50, in __init__
:    DeviceList.__init__(self, adapter, data)
:  File "/usr/lib/python2.7/site-packages/blueman/gui/DeviceList.py", line 122, in __init__
:    self.SetAdapter(adapter)
:  File "/usr/lib/python2.7/site-packages/blueman/gui/DeviceList.py", line 332, in SetAdapter
:    except dbus.DBusServiceUnknownError:
:AttributeError: 'module' object has no attribute 'DBusServiceUnknownError'
:
:Local variables in innermost frame:
:adapter: None
:self: <DeviceSelectorList object at 0x19c69b0 (blueman+gui+DeviceList+DeviceList at 0x1bd8300)>
Comment 1 Zahir Toufie 2012-10-15 19:08:27 EDT
Created attachment 627785 [details]
File: core_backtrace
Comment 2 Zahir Toufie 2012-10-15 19:19:31 EDT
I've also tried to pair and connect to my Acer Bluetooth Mouse, model HSTNC-002W using KDE but then I get this in my /var/log/messages

Oct 16 07:48:10 mzt kernel: [  200.126439] ------------[ cut here ]------------
Oct 16 07:48:10 mzt kernel: [  200.126455] WARNING: at fs/sysfs/dir.c:529 sysfs_add_one+0xca/0x100()
Oct 16 07:48:10 mzt kernel: [  200.126457] Hardware name: Aspire 8950G
Oct 16 07:48:10 mzt kernel: [  200.126460] sysfs: cannot create duplicate filename '/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.5/2-1.5:1.0/bluetooth/hci0/hci0:11'
Oct 16 07:48:10 mzt kernel: [  200.126462] Modules linked in: ebtable_nat ebtables michael_mic arc4 ipt_MASQUERADE iptable_nat nf_nat hidp xt_CHECKSUM iptable_mangle bridge be2iscsi iscsi_boot_sysfs stp bnx2i llc lockd cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi sunrpc ib_iser rfcomm bnep rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp nf_conntrack_ipv4 ip6t_REJECT libiscsi nf_defrag_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack scsi_transport_iscsi ip6table_filter ip6_tables fuse lib80211_crypt_tkip fglrx(PO) wl(PO) btusb snd_hda_codec_hdmi vhost_net snd_hda_codec_realtek bluetooth snd_hda_intel tun macvtap macvlan snd_hda_codec mei uvcvideo cfg80211 lpc_ich snd_hwdep r8169 videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_seq snd_seq_device snd_pcm acer_wmi mii media amd_iommu_v2 mfd_core i2c_i801 coretemp sparse_keymap rfkill snd_page_alloc snd_timer snd lib80211 soundcore serio_raw kvm_intel kvm microcode uinput binfmt_misc joydev xts gf128mul dm_cry
Oct 16 07:48:10 mzt kernel: pt crc32c_intel ghash_clmulni_intel wmi video radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
Oct 16 07:48:10 mzt kernel: [  200.126635] Pid: 73, comm: kworker/u:4 Tainted: P      D    O 3.5.6-1.fc17.x86_64 #1
Oct 16 07:48:10 mzt kernel: [  200.126645] Call Trace:
Oct 16 07:48:10 mzt kernel: [  200.126659]  [<ffffffff8105864f>] warn_slowpath_common+0x7f/0xc0
Oct 16 07:48:10 mzt kernel: [  200.126667]  [<ffffffff81058746>] warn_slowpath_fmt+0x46/0x50
Oct 16 07:48:10 mzt kernel: [  200.126673]  [<ffffffff811f8efa>] sysfs_add_one+0xca/0x100
Oct 16 07:48:10 mzt kernel: [  200.126679]  [<ffffffff811f9128>] create_dir+0x78/0xd0
Oct 16 07:48:10 mzt kernel: [  200.126684]  [<ffffffff811f94b6>] sysfs_create_dir+0x86/0xe0
Oct 16 07:48:10 mzt kernel: [  200.126691]  [<ffffffff812cfec8>] kobject_add_internal+0x98/0x260
Oct 16 07:48:10 mzt kernel: [  200.126699]  [<ffffffff812d9111>] ? vsnprintf+0x461/0x600
Oct 16 07:48:10 mzt kernel: [  200.126704]  [<ffffffff812d03f7>] kobject_add+0x67/0xc0
Oct 16 07:48:10 mzt kernel: [  200.126711]  [<ffffffff813b26a9>] device_add+0x119/0x6e0
Oct 16 07:48:10 mzt kernel: [  200.126717]  [<ffffffff813b0e51>] ? dev_set_name+0x41/0x50
Oct 16 07:48:10 mzt kernel: [  200.126742]  [<ffffffffa0376ac4>] hci_conn_add_sysfs+0x54/0xc0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.126763]  [<ffffffffa0368910>] hci_conn_complete_evt.isra.46+0xe0/0x3c0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.126773]  [<ffffffffa036b4d8>] hci_event_packet+0xee8/0x2680 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.126783]  [<ffffffffa03759df>] ? hci_send_to_sock+0xff/0x1e0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.126787]  [<ffffffff814f1d87>] ? __kfree_skb+0x47/0xa0
Oct 16 07:48:10 mzt kernel: [  200.126790]  [<ffffffff814f1e16>] ? kfree_skb+0x36/0xa0
Oct 16 07:48:10 mzt kernel: [  200.126800]  [<ffffffffa03759df>] ? hci_send_to_sock+0xff/0x1e0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.126809]  [<ffffffffa035db48>] hci_rx_work+0x1e8/0x430 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.126813]  [<ffffffff81075f99>] process_one_work+0x129/0x400
Oct 16 07:48:10 mzt kernel: [  200.126821]  [<ffffffffa035d960>] ? hci_send_frame+0xc0/0xc0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.126824]  [<ffffffff810765c6>] worker_thread+0x126/0x2e0
Oct 16 07:48:10 mzt kernel: [  200.126827]  [<ffffffff810764a0>] ? rescuer_thread+0x1f0/0x1f0
Oct 16 07:48:10 mzt kernel: [  200.126831]  [<ffffffff8107b183>] kthread+0x93/0xa0
Oct 16 07:48:10 mzt kernel: [  200.126836]  [<ffffffff81616b64>] kernel_thread_helper+0x4/0x10
Oct 16 07:48:10 mzt kernel: [  200.126851]  [<ffffffff8107b0f0>] ? kthread_freezable_should_stop+0x70/0x70
Oct 16 07:48:10 mzt kernel: [  200.126857]  [<ffffffff81616b60>] ? gs_change+0x13/0x13
Oct 16 07:48:10 mzt kernel: [  200.126861] ---[ end trace 625ba980226e749c ]---

and

Oct 16 07:48:10 mzt kernel: [  200.126866] ------------[ cut here ]------------
Oct 16 07:48:10 mzt kernel: [  200.126871] WARNING: at lib/kobject.c:196 kobject_add_internal+0x1f4/0x260()
Oct 16 07:48:10 mzt kernel: [  200.126873] Hardware name: Aspire 8950G
Oct 16 07:48:10 mzt kernel: [  200.126876] kobject_add_internal failed for hci0:11 with -EEXIST, don't try to register things with the same name in the same directory.
Oct 16 07:48:10 mzt kernel: [  200.126878] Modules linked in: ebtable_nat ebtables michael_mic arc4 ipt_MASQUERADE iptable_nat nf_nat hidp xt_CHECKSUM iptable_mangle bridge be2iscsi iscsi_boot_sysfs stp bnx2i llc lockd cnic uio cxgb4i cxgb4 cxgb3i cxgb3 mdio libcxgbi sunrpc ib_iser rfcomm bnep rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp nf_conntrack_ipv4 ip6t_REJECT libiscsi nf_defrag_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack scsi_transport_iscsi ip6table_filter ip6_tables fuse lib80211_crypt_tkip fglrx(PO) wl(PO) btusb snd_hda_codec_hdmi vhost_net snd_hda_codec_realtek bluetooth snd_hda_intel tun macvtap macvlan snd_hda_codec mei uvcvideo cfg80211 lpc_ich snd_hwdep r8169 videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_seq snd_seq_device snd_pcm acer_wmi mii media amd_iommu_v2 mfd_core i2c_i801 coretemp sparse_keymap rfkill snd_page_alloc snd_timer snd lib80211 soundcore serio_raw kvm_intel kvm microcode uinput binfmt_misc joydev xts gf128mul dm_cry
Oct 16 07:48:10 mzt kernel: pt crc32c_intel ghash_clmulni_intel wmi video radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
Oct 16 07:48:10 mzt kernel: [  200.126996] Pid: 73, comm: kworker/u:4 Tainted: P      D W  O 3.5.6-1.fc17.x86_64 #1
Oct 16 07:48:10 mzt kernel: [  200.126997] Call Trace:
Oct 16 07:48:10 mzt kernel: [  200.127004]  [<ffffffff8105864f>] warn_slowpath_common+0x7f/0xc0
Oct 16 07:48:10 mzt kernel: [  200.127011]  [<ffffffff81058746>] warn_slowpath_fmt+0x46/0x50
Oct 16 07:48:10 mzt kernel: [  200.127016]  [<ffffffff812d0024>] kobject_add_internal+0x1f4/0x260
Oct 16 07:48:10 mzt kernel: [  200.127023]  [<ffffffff812d9111>] ? vsnprintf+0x461/0x600
Oct 16 07:48:10 mzt kernel: [  200.127027]  [<ffffffff812d03f7>] kobject_add+0x67/0xc0
Oct 16 07:48:10 mzt kernel: [  200.127034]  [<ffffffff813b26a9>] device_add+0x119/0x6e0
Oct 16 07:48:10 mzt kernel: [  200.127039]  [<ffffffff813b0e51>] ? dev_set_name+0x41/0x50
Oct 16 07:48:10 mzt kernel: [  200.127057]  [<ffffffffa0376ac4>] hci_conn_add_sysfs+0x54/0xc0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.127073]  [<ffffffffa0368910>] hci_conn_complete_evt.isra.46+0xe0/0x3c0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.127089]  [<ffffffffa036b4d8>] hci_event_packet+0xee8/0x2680 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.127105]  [<ffffffffa03759df>] ? hci_send_to_sock+0xff/0x1e0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.127111]  [<ffffffff814f1d87>] ? __kfree_skb+0x47/0xa0
Oct 16 07:48:10 mzt kernel: [  200.127116]  [<ffffffff814f1e16>] ? kfree_skb+0x36/0xa0
Oct 16 07:48:10 mzt kernel: [  200.127132]  [<ffffffffa03759df>] ? hci_send_to_sock+0xff/0x1e0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.127148]  [<ffffffffa035db48>] hci_rx_work+0x1e8/0x430 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.127153]  [<ffffffff81075f99>] process_one_work+0x129/0x400
Oct 16 07:48:10 mzt kernel: [  200.127168]  [<ffffffffa035d960>] ? hci_send_frame+0xc0/0xc0 [bluetooth]
Oct 16 07:48:10 mzt kernel: [  200.127174]  [<ffffffff810765c6>] worker_thread+0x126/0x2e0
Oct 16 07:48:10 mzt kernel: [  200.127179]  [<ffffffff810764a0>] ? rescuer_thread+0x1f0/0x1f0
Oct 16 07:48:10 mzt kernel: [  200.127185]  [<ffffffff8107b183>] kthread+0x93/0xa0
Oct 16 07:48:10 mzt kernel: [  200.127192]  [<ffffffff81616b64>] kernel_thread_helper+0x4/0x10
Oct 16 07:48:10 mzt kernel: [  200.127198]  [<ffffffff8107b0f0>] ? kthread_freezable_should_stop+0x70/0x70
Oct 16 07:48:10 mzt kernel: [  200.127205]  [<ffffffff81616b60>] ? gs_change+0x13/0x13
Oct 16 07:48:10 mzt kernel: [  200.127208] ---[ end trace 625ba980226e749d ]---
Oct 16 07:48:10 mzt kernel: [  200.127213] Bluetooth: Failed to register connection device
Comment 3 Zahir Toufie 2012-10-15 19:31:05 EDT
There also additonal information available as I've previously logged this problem via this Bugzilla bug 729871 here https://bugzilla.redhat.com/show_bug.cgi?id=729871.
Comment 4 Bastien Nocera 2012-10-16 02:09:21 EDT
blueman crashes should be filed against blueman. File separate bugs for the kernel bugs (and don't reassign them to bluez either).
Comment 5 Zahir Toufie 2012-10-16 16:55:13 EDT
Sorry man, been awhile since I've worked on this stuff. Will remember for next time.
Comment 6 Zahir Toufie 2013-04-29 20:26:51 EDT
Woohoo, looks like my mouse is now pairing correctly and usable under the latest FC18 Kernel and Bluez.

Installation details;

$ uname -a
Linux mzt.alludra.com 3.8.9-200.fc18.x86_64 #1 SMP Fri Apr 26 12:50:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

$ rpm -qa | grep bluez
bluez-4.101-6.fc18.x86_64
bluez-compat-4.101-6.fc18.x86_64
bluez-cups-4.101-6.fc18.x86_64
bluez-gstreamer-4.101-6.fc18.x86_64
bluez-hcidump-2.4-2.fc18.x86_64
bluez-hid2hci-4.101-6.fc18.x86_64
bluez-libs-4.101-6.fc18.x86_64

Thanks for fixing this one guys :-)

Note You need to log in before you can comment on or make changes to this bug.