Bug 866708 - caps.py reports half cpu core count in AMD processors
caps.py reports half cpu core count in AMD processors
Status: CLOSED DUPLICATE of bug 833425
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Antoni Segura Puimedon
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-15 19:10 EDT by Antoni Segura Puimedon
Modified: 2014-01-12 19:54 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 05:33:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antoni Segura Puimedon 2012-10-15 19:10:37 EDT
Description of problem: The new libvirt based detection of cpu capabilities does not function properly with some AMD processors like:

- Opteron 6234 reports 6 cores instead of 12.
- Opteron 6272 reports 8 cores instead of 16.

Version-Release number of selected component (if applicable): vdsm-4.10.0-10.fc17.x86_64


How reproducible: 100%


Steps to Reproduce:
1. vdsClient 0 getVdsCaps
  
Actual results:
Core count 6 (for Opteron 6234)

Expected results:
Core count 12 (for Opteron 6234)

Additional info:
libvirt xml capabilites:
http://pastebin.com/i1WEWVRC
Comment 1 Erik Meijer 2012-10-15 19:20:18 EDT
In addition ovirt detects the CPU as being a "AMD Opteron G1" and libvirt reports the cpu as a "AMD Opteron G4".
Comment 2 Erik Meijer 2012-10-15 19:26:56 EDT
The CPU details from vdsClient:

"	cpuCores = 6
	cpuFlags = fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,mmx,fxsr,sse,sse2,ht,syscall,nx,mmxext,fxsr_opt,pdpe1gb,rdtscp,lm,constant_tsc,rep_good,nopl,nonstop_tsc,extd_apicid,amd_dcm,aperfmperf,pni,pclmulqdq,monitor,ssse3,cx16,sse4_1,sse4_2,popcnt,aes,xsave,avx,lahf_lm,cmp_legacy,svm,extapic,cr8_legacy,abm,sse4a,misalignsse,3dnowprefetch,osvw,ibs,xop,skinit,wdt,lwp,fma4,nodeid_msr,topoext,perfctr_core,arat,cpb,hw_pstate,npt,lbrv,svm_lock,nrip_save,tsc_scale,vmcb_clean,flushbyasid,decodeassists,pausefilter,pfthreshold,model_Opteron_G1
	cpuModel = AMD Opteron(TM) Processor 6234
	cpuSockets = 1
"
Comment 3 Barak 2012-10-16 05:33:53 EDT

*** This bug has been marked as a duplicate of bug 833425 ***
Comment 4 Dan Kenigsberg 2012-10-16 09:53:23 EDT
Actually, it's mostly a dup of bug 737104

(01:34:04 PM) danken: Meyer__: which version of vdsm are you using?
(01:34:16 PM) Meyer__: danken: vdsm-4.10.0-10.fc17.x86_64
(01:36:24 PM) danken: Meyer__: gasp
(01:36:42 PM) danken: this explains a lot of stuff. you are missing http://gerrit.ovirt.org/5035
(01:37:01 PM) danken: that handles several CPUs properly
(01:37:32 PM) danken: *and* you are missing the report-threads-as-cores hack http://gerrit.ovirt.org/7097
(01:37:45 PM) Meyer__: danken: Oh, but 4.10.0-10 is the latest stable version no?
(01:37:52 PM) danken: it is :-(
(01:37:57 PM) danken: Meyer__: ^^
(01:38:45 PM) Meyer__: danken: Any idea of when it will be rolled out to the stable branch?
(01:39:02 PM) danken: worse case in ovirt-3.2 release
(01:39:16 PM) Meyer__: If its soon i might wait, if it's not i might steal those patches
(01:39:34 PM) danken: http://wiki.ovirt.org/wiki/OVirt_3.2_release-management
(01:39:59 PM) danken: beta release in one month
(01:40:52 PM) danken: you can try to snatch vdsm.caps from upstream
(01:40:57 PM) danken: just to see if it works for you
(01:41:42 PM) Meyer__: danken: yeah, its mostly the caps that I would like to get sorted out. The CPU count is not that important
(01:42:10 PM) danken: I think the cpu count would also get fixed if you take caps.py
(01:43:17 PM) Meyer__: danken: [u'model_Opteron_G3', u'model_Opteron_G1', u'model_Opteron_G4', u'model_Opteron_G2']
(01:43:21 PM) Meyer__: danken: :)
(01:45:33 PM) Meyer__: danken: thanks

Note You need to log in before you can comment on or make changes to this bug.