Bug 866717 - f18 anaconda cannot use the selected disk (continue button remains grayed out and the disks does 'not count' for anaconda) (reproduced)
f18 anaconda cannot use the selected disk (continue button remains grayed out...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-15 21:15 EDT by Reartes Guillermo
Modified: 2012-11-08 04:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:24:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot of the issue (65.38 KB, image/png)
2012-10-15 21:15 EDT, Reartes Guillermo
no flags Details
another screenshot of the issue (62.02 KB, image/png)
2012-10-15 21:16 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2012-10-15 21:15:24 EDT
Created attachment 627827 [details]
screenshot of the issue

Description of problem:

The second disk can be selected, it is (for yet unknown reasons) not
usable for anaconda. The 'continue' button remain grayed out.
Also selecting the two disk shows only the first is counted.


Version-Release number of selected component (if applicable):
F18b TC4

How reproducible:
happened once

Steps to Reproduce:
i could not reproduce it yet.

Actual results:
only the first disk is usable.

Expected results:
both disks should be usable.

Additional info:

I also observed 'mini-stucks' as i move throug the UI trying to get
rid of the issue, similar to previous 'stuck situations', i was able to exit such events by ALT+TAB then ESC. (anaconda was stuck, not frozen) 

I could not reproduce neither the issue described nor this events. (which happened on the same try).
Comment 1 Reartes Guillermo 2012-10-15 21:16:00 EDT
Created attachment 627828 [details]
another screenshot of the issue
Comment 2 Reartes Guillermo 2012-10-15 21:16:48 EDT
I don't have really much info about this, i was going back and forth manual to custom with 2 then 1 disk and got this.
Comment 3 Reartes Guillermo 2012-10-15 22:09:41 EDT
Found how-to reproduce it:

1- go to storage

2- select both disks, the return to the main hub

3- 'automatic partitioning selected' (it is in my opinion a --different-- bug, since the selected disks might contain data and 'begin installation' is NOT grayed out, so no warning was issued).

4- enter storage again

5- deselect second disk, return to the main hub, "error checking storage configuration" will be shown

6- enter storage again

7- double click yellow banner "not enough space on disks for automatic partitioning).. press MODIFY STORAGE LAYOUT

8- if you select the second disk, the issue is reproduced as shown in previous snapshot.
Comment 4 David Lehman 2012-10-30 16:51:52 EDT
Another reproducer:

1. Enter storage, select one of multiple disks
2. Continue to reclaim dialog
3. Hit Cancel
4. Re-enter storage, try to select more disks

Expected: Allows selection of additional disks.
Actual: Clicks on disks other than the one previously selected have no effect.


I have a patch that fixes this issue.
Comment 5 Adam Williamson 2012-10-31 13:54:11 EDT
Discussed at 2012-10-31 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-31/f18beta-blocker-review-6.2012-10-31-16.00.log.txt . This clearly impacts testability of the disk selection process and cannot be fixed with an upgrade. It is accepted as NTH.
Comment 6 Fedora Update System 2012-11-02 00:04:20 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 7 Fedora Update System 2012-11-02 14:38:48 EDT
Package anaconda-18.23-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.23-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17509/anaconda-18.23-1.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-11-02 21:03:42 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 9 Fedora Update System 2012-11-03 15:28:21 EDT
Package anaconda-18.24-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.24-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17543/anaconda-18.24-1.fc18
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-11-05 20:38:54 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 11 Fedora Update System 2012-11-06 21:10:51 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 12 Adam Williamson 2012-11-08 04:24:11 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.