This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 866736 - [hck][svvp] PCI Hardware Compliance Test for Systems job failed when e1000 is in use
[hck][svvp] PCI Hardware Compliance Test for Systems job failed when e1000 is...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Michael S. Tsirkin
Virtualization Bugs
: ZStream
Depends On:
Blocks: 873270
  Show dependency treegraph
 
Reported: 2012-10-15 22:47 EDT by Mike Cao
Modified: 2013-02-21 02:40 EST (History)
12 users (show)

See Also:
Fixed In Version: qemu-kvm-0.12.1.2-2.330.el6
Doc Type: Bug Fix
Doc Text:
In the SVVP (Server Virtualization Validation Program) environment, when the e1000 network driver was used, the PCI Hardware Compliance Test For Systems job failed. Consequently, the HCK (Hardware Certification Kit) SVVP certification could not be passed on the system. A patch has been provided to address this issue and the test now passes in the described scenario.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 02:40:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
job logs for stratch builds (33.25 KB, application/octet-stream)
2012-10-18 06:28 EDT, Mike Cao
no flags Details
all logs (67.42 KB, text/plain)
2012-10-18 06:45 EDT, Mike Cao
no flags Details

  None (edit)
Description Mike Cao 2012-10-15 22:47:39 EDT
Steps to Reproduce:
When test SVVP for RHEL6.3 ,PCI Hardware Compliance Test For Systems failed in task Process Logged Messages,there are 4 failures in whole except for the Root BUS has a Errata.Details is described in the failure log files attached.

Version-Release number of selected component (if applicable):
Kernel-2.6.32-301.el6.x86_64
qemu-kvm-0.12.1.2-2.307.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare the SVVP test Environment
2.Add 10 windows 2012 guests in one machine,create a submission for SVVP ,select the MC ,SC and SUT, the sut use e1000 network
3. Run PCI Hardware Compliance Test For Systems job
  
Actual results:
job failed


Expected results:
job should pass

Additional info:
Comment 1 Mike Cao 2012-10-15 22:48:08 EDT
log :
Start Test 10/16/2012 10:39:01.756 AM PCI Function @ 0.9.0 
Message 10/16/2012 10:39:01.756 AM Testing PCI function at location 00000000.09.00  
Message 10/16/2012 10:39:01.756 AM Not found 
Message 10/16/2012 10:39:01.756 AM Please wait... 
Message 10/16/2012 10:39:01.756 AM [PROFILE] Location = Bus: 00000000h, Device: 09h, Function: 0h 
Message 10/16/2012 10:39:01.756 AM [PROFILE] VendorID = 8086h: Intel Corporation 
Message 10/16/2012 10:39:01.756 AM [PROFILE] DeviceID = 100Eh: 82540EM Gigabit Ethernet Controller 
Message 10/16/2012 10:39:01.756 AM [PROFILE] Revision = 3h 
Message 10/16/2012 10:39:01.756 AM [PROFILE] SubSVid = 1AF4h: <Not Found> 
Message 10/16/2012 10:39:01.756 AM [PROFILE] SubSysId = 1100h 
Message 10/16/2012 10:39:01.756 AM [PROFILE] Header = 00h 
Message 10/16/2012 10:39:01.756 AM [PROFILE] ClassCode= 020000h 
Message 10/16/2012 10:39:01.756 AM [PROFILE] BaseClass= Network Controller 
Message 10/16/2012 10:39:01.756 AM [PROFILE] SubClass = Ethernet 
Message 10/16/2012 10:39:01.756 AM Not a PCI-Express Device 
End Test 10/16/2012 10:39:01.756 AM PCI Function @ 0.9.0 
Result:   Fail 
Repro:   "C:\Program Files\KmLog2\KmLogTransform.exe" -OutFile Out.Txt -CreateLog -LogFile PciHct.WTL -CloseLog -rollup -guid BF0EDF7D-F02B-4E1f-A9FF-3B1CEBA22E72 KmLogProviders.etl 
 
  Failed 
 Start Test 10/16/2012 10:39:01.756 AM PCI capabilities list 
Error 10/16/2012 10:39:01.756 AM Assertion 44D27133-2DA6-4B15-BF03-476FD1BFE0F0: FAILED. Capabilities Pointer register of the Header table cannot have a value of 0h if the Status register indicates otherwise. 
File:   <Unspecified file> Line: 0 
Error Type:   NT_STATUS 
Error Code:   0xc0000420 
Error Text:   Error 0xc0000420 
Message 10/16/2012 10:39:01.756 AM Assertion ECC23ECE-0046-4F51-8500-E17639E42334: Passed. 
End Test 10/16/2012 10:39:01.756 AM PCI capabilities list 
Result:   Fail 
Repro:   "C:\Program Files\KmLog2\KmLogTransform.exe" -OutFile Out.Txt -CreateLog -LogFile PciHct.WTL -CloseLog -rollup -guid BF0EDF7D-F02B-4E1f-A9FF-3B1CEBA22E72 KmLogProviders.etl
Comment 2 Mike Cao 2012-10-15 22:49:30 EDT
This is a old bug ,if we want to use e1000 to pass svvp ,this bug must be fixed . use rtl8139 will not hit this issue

-developer's comment in Bug 581775

Yan Vugenfirer 2010-05-05 15:17:13 CST 
Should be fixed in QEMU.

The test complains on inconsistency in Intel's NIC (e1000) configuration space.


Comment 4 Dor Laor 2010-05-05 16:46:20 CST I tend to close it as won't fix since we do not intend to svvp e1000.
We do plan to pass with virtio.
Comment 5 Mike Cao 2012-10-18 04:55:33 EDT
Hi, MSt 

Tried the strach build ,the sub testing results is "warning" ,while the WHQL Testing results is "Pass" at last 


  Warning 
 Start Test 10/18/2012 4:28:56.730 PM PCI Function @ 0.9.0 
Message 10/18/2012 4:28:56.730 PM Testing PCI function at location 00000000.09.00  
Message 10/18/2012 4:28:56.730 PM Not found 
Message 10/18/2012 4:28:56.730 PM Please wait... 
Message 10/18/2012 4:28:56.730 PM [PROFILE] Location = Bus: 00000000h, Device: 09h, Function: 0h 
Message 10/18/2012 4:28:56.730 PM [PROFILE] VendorID = 8086h: Intel Corporation 
Message 10/18/2012 4:28:56.730 PM [PROFILE] DeviceID = 100Eh: 82540EM Gigabit Ethernet Controller 
Message 10/18/2012 4:28:56.730 PM [PROFILE] Revision = 3h 
Message 10/18/2012 4:28:56.730 PM [PROFILE] SubSVid = 1AF4h: <Not Found> 
Message 10/18/2012 4:28:56.730 PM [PROFILE] SubSysId = 1100h 
Message 10/18/2012 4:28:56.730 PM [PROFILE] Header = 00h 
Message 10/18/2012 4:28:56.730 PM [PROFILE] ClassCode= 020000h 
Message 10/18/2012 4:28:56.730 PM [PROFILE] BaseClass= Network Controller 
Message 10/18/2012 4:28:56.730 PM [PROFILE] SubClass = Ethernet 
Message 10/18/2012 4:28:56.730 PM Not a PCI-Express Device 
End Test 10/18/2012 4:28:56.730 PM PCI Function @ 0.9.0 
Result:   Warn 
Repro:   "C:\Program Files\KmLog2\KmLogTransform.exe" -OutFile Out.Txt -CreateLog -LogFile PciHct.WTL -CloseLog -rollup -guid BF0EDF7D-F02B-4E1f-A9FF-3B1CEBA22E72 KmLogProviders.etl 
 
  Passed 
 Start Test 10/18/2012 4:28:56.730 PM PCI capabilities list 
End Test 10/18/2012 4:28:56.730 PM PCI capabilities list 
Result:   Pass 
Repro:   "C:\Program Files\KmLog2\KmLogTransform.exe" -OutFile Out.Txt -CreateLog -LogFile PciHct.WTL -CloseLog -rollup -guid BF0EDF7D-F02B-4E1f-A9FF-3B1CEBA22E72 KmLogProviders.etl 


Based on above ,I think your patch fix this bug 

Mike
Comment 7 Mike Cao 2012-10-18 06:28:33 EDT
Created attachment 629301 [details]
job logs for stratch builds
Comment 8 Mike Cao 2012-10-18 06:45:01 EDT
Created attachment 629312 [details]
all logs
Comment 9 Michael S. Tsirkin 2012-10-18 06:45:51 EDT
ok this is the warning:
<Warn ^M
        File="&lt;Unspecified file&gt;" ^M
        Line="0" ^M
        UserText="Assertion 5CB2102-1603-4ACE-8A03-FFD777E987F0: Failed with a WARNING.  Bit 10 (Interrupt Disable) in the Command register (offset 4h) in the Header table must be read-writable if the device supports an interrupt." CA="835907" LA="840327" >^M
        <rti id="3124255527" />^M
        <ctx id="1406515444" />^M
</Warn>^M

This warning is too risky to fix for 6.4. Fixed upstream
commit a7b15a5cc6261629879d4d8a71bacf23f983000b .
Please open a separate bugzilla and we will consider for 6.5.
Comment 10 Ronen Hod 2012-10-18 07:47:38 EDT
PM,

This bug fix is important since without it we do not have a safe way to pass HCK SVVP certification. To be honest, I am not 100% sure that we will go with E1000, but we need to have this option available.

Thanks, Ronen.
Comment 12 Michael S. Tsirkin 2012-10-18 11:20:55 EDT
new scratch build:
https://brewweb.devel.redhat.com/taskinfo?taskID=4993498
fixing an issue noted by Jason Baron.

QE could you pls retest and also test cross version migration to/from RHEL6.3
(specifying -M rhel6.3.0 just for cross version test but not for
SVVP test) with this build?

Thanks!
Comment 13 Mike Cao 2012-10-18 11:36:53 EDT
junyi

Could you arrange functional test on the scratch builds according to comment 12?

Thanks,
Mike
Comment 14 juzhang 2012-10-18 22:27:55 EDT
(In reply to comment #13)
> junyi
> 
> Could you arrange functional test on the scratch builds according to comment
> 12?
> 
> Thanks,
> Mike

Hi, Mike/Michael

KVM QE will arrange a compatibility functional between rhel6.3.z and rhel6.0 by using this private build next week. Will update the result in this issue once we get. 

Best Regards & Thanks,
Junyi
Comment 19 Mike Cao 2012-10-29 23:04:54 EDT
SVVP test has been passed on qemu-kvm build 330
Comment 22 errata-xmlrpc 2013-02-21 02:40:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0527.html

Note You need to log in before you can comment on or make changes to this bug.