Bug 866771 - GParted is unable to resize NTFS partition, because it's mounted.
GParted is unable to resize NTFS partition, because it's mounted.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gparted (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 02:04 EDT by Paul
Modified: 2013-07-20 05:49 EDT (History)
1 user (show)

See Also:
Fixed In Version: gparted-0.16.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-20 05:42:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul 2012-10-16 02:04:05 EDT
Description of problem:
GParted is unable to extend size of Windows partition. Looks like something is mounting my partition during resize process.

Version-Release number of selected component (if applicable):
The one from Fedora 17 and 18 for sure. Probably earlier too.

How reproducible:
Always

Steps to Reproduce:
1. Prepare a disk with NTFS partition on /dev/sda1, and some unused space between this partition and the next one. (in my case I used Paragon Hard Disk Manager to extend first partition at cost of second, but only shrinking of the second partition was done due to error)
2. Boot your installation of Fedora and launch GParted.
3. Umount partition using GParted or command line.
4. Use resize dialog in GParted to increase sda1 size.
5. Apply changes to your HDD.
  
Actual results:
Error message appears indicating that /dev/sda1 is mounted and should be treated with 'umount'.

Expected results:
The drive is properly resized.

Additional info:
I have /dev/sda1 added to fstab as /mnt/WindowsC. This directory exist, and Windows is being properly mounted after each boot.
Fedora was booted from the same disk.

Workaround:
On the step 5 I need to confirm the operation. umounting it manually before clicking OK button removes the issue, however another error appears later. It's extends the partition to desired size, but I had to use "ntfsresize /dev/sda1" manually to make this change visible in Windows explorer.
Comment 1 Fedora Update System 2013-06-11 12:36:27 EDT
gparted-0.16.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gparted-0.16.1-2.fc18
Comment 2 Fedora Update System 2013-06-11 12:37:25 EDT
gparted-0.16.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gparted-0.16.1-2.fc19
Comment 3 Fedora Update System 2013-06-11 12:38:17 EDT
gparted-0.16.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gparted-0.16.1-1.fc17
Comment 4 Fedora Update System 2013-06-11 22:37:14 EDT
Package gparted-0.16.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gparted-0.16.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10621/gparted-0.16.1-2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-20 05:42:37 EDT
gparted-0.16.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-07-20 05:48:22 EDT
gparted-0.16.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2013-07-20 05:49:10 EDT
gparted-0.16.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.