Bug 866884 - RFE: Add inst.httpd option which start http server on / in anaconda
RFE: Add inst.httpd option which start http server on / in anaconda
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 05:01 EDT by Pavel Holica
Modified: 2012-10-16 10:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 10:11:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Holica 2012-10-16 05:01:09 EDT
Description of problem:
There could be running http server on / (something like python -m SimpleHTTPServer) providing easy access to all logs and other files during installation. This would be great improvement for debugging during installation.

There is already inst.sshd which provides similar functionality but I believe that http is way easier and is worth it.
Comment 1 Martin Sivák 2012-10-16 09:49:35 EDT
It should be possible to add a systemd target to initrd overlay. Not 100% user friendly, but already there.
Comment 2 Chris Lumens 2012-10-16 10:11:51 EDT
We also already provide syslogging capabilities to log to a remote system, too.  Honestly I don't want to add another mechanism, because that's just going to be another thing we'll have to debug and maintain.  We've already got similar enough functionality.

Note You need to log in before you can comment on or make changes to this bug.