Bug 866886 - ovirt-engine-backend : unexpected behavior when restarting vdsm service during VM pool creation .
ovirt-engine-backend : unexpected behavior when restarting vdsm service durin...
Status: CLOSED DUPLICATE of bug 856203
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 05:07 EDT by Oded Ramraz
Modified: 2012-10-16 06:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 06:12:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs ( pool creation is around 15/10 16:01 ) (558.04 KB, application/zip)
2012-10-16 05:11 EDT, Oded Ramraz
no flags Details
vdsm logs ( pool creation is around 15/10 16:01 ) (1.47 MB, application/zip)
2012-10-16 05:17 EDT, Oded Ramraz
no flags Details

  None (edit)
Description Oded Ramraz 2012-10-16 05:07:11 EDT
Description of problem:

After restarting vdsm service on my SPM during VM pool creation I noticed that few VM's were stuck in image locked state for more than 24 hours  ( even though the task state is finished in vdsm ) .
Attached relevant log files . 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

[root@blue-vdsb ~]# vdsClient -s 0 getAllTasksStatuses
{'status': {'message': 'OK', 'code': 0}, 'allTasksStatus': {'d20f5a09-9afb-4b9b-b3d3-b44659cc11e8': {'message': '1 jobs completed successfully', 'code': 0, 'taskID': 'd20f5a09-9afb-4b9b-b3d3-b44659cc11e8', 'taskResult': 'success', 'taskState': 'finished'}, 'f0575dbb-7bdf-44ae-9768-2f14c481712e': {'message': 'Task is initializing', 'code': 0, 'taskID': 'f0575dbb-7bdf-44ae-9768-2f14c481712e', 'taskResult': 'cleanSuccess', 'taskState': 'finished'}, '469f9ee4-9dba-4698-ad71-63912dff466f': {'message': '1 jobs completed successfully', 'code': 0, 'taskID': '469f9ee4-9dba-4698-ad71-63912dff466f', 'taskResult': 'success', 'taskState': 'finished'}, 'e86aeaba-bd9f-484d-9e0c-c7b5dcafab1c': {'message': '1 jobs completed successfully', 'code': 0, 'taskID': 'e86aeaba-bd9f-484d-9e0c-c7b5dcafab1c', 'taskResult': 'success', 'taskState': 'finished'}}}

[root@blue-vdsb ~]# vdsClient -s 0 getAllTasksInfo 
d20f5a09-9afb-4b9b-b3d3-b44659cc11e8 :
        verb = createVolume
        id = d20f5a09-9afb-4b9b-b3d3-b44659cc11e8
f0575dbb-7bdf-44ae-9768-2f14c481712e :
        verb = createVolume
        id = f0575dbb-7bdf-44ae-9768-2f14c481712e
469f9ee4-9dba-4698-ad71-63912dff466f :
        verb = createVolume
        id = 469f9ee4-9dba-4698-ad71-63912dff466f
e86aeaba-bd9f-484d-9e0c-c7b5dcafab1c :
        verb = createVolume
        id = e86aeaba-bd9f-484d-9e0c-c7b5dcafab1c
Comment 1 Oded Ramraz 2012-10-16 05:11:20 EDT
Created attachment 628052 [details]
engine logs ( pool creation is around 15/10 16:01 )
Comment 2 Oded Ramraz 2012-10-16 05:17:46 EDT
Created attachment 628055 [details]
vdsm logs ( pool creation is around 15/10 16:01 )
Comment 3 Haim 2012-10-16 06:12:36 EDT

*** This bug has been marked as a duplicate of bug 856203 ***

Note You need to log in before you can comment on or make changes to this bug.