Bug 866890 - virt-who support Hyper-V problems
virt-who support Hyper-V problems
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-who (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 05:15 EDT by lzhuang
Modified: 2016-11-30 19:31 EST (History)
3 users (show)

See Also:
Fixed In Version: virt-who-0.8-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 04:50:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lzhuang 2012-10-16 05:15:36 EDT
Description of problem:
There are 3 problems:
1. The help info for Hyper-V is not correct
2. hyperv.py has some problems for error: AttributeError: HyperV instance has no attribute 'ping'
3. Should uuid of snapshot of a VM should be sent by virt-who?

Version-Release number of selected component (if applicable):
virt-who-0.8-2.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. For problem 1: 
   # virt-who --help
   It will return the following info for Hyper-V:

   RHEV-M options:
   ^^^^^^^^^^

      Use this options with --hyperv

      --hyperv-owner=OWNER
                        Organization who has purchased subscriptions of the
                        products
      --hyperv-env=ENV    Environment where the Hyper-V belongs to
      --hyperv-server=SERVER
                        URL of the Hyper-V server to connect to
      --hyperv-username=USERNAME
                        Username for connecting to Hyper-V
      --hyperv-password=PASSWORD
                        Password for connecting to Hyper-V
   
   It should be "HYPER-V options:"

2. For problem 2: 
   # virt-who --hyperv --hyperv-owner=ACME_Corporation --hyperv-env=env1 --hyperv-server=10.66.13.142 --hyperv-username=Administrator --hyperv-password=qwer1234P -d -i 1
     ERROR: Fatal error:
     Traceback (most recent call last):
       File "/usr/share/virt-who/virt-who.py", line 514, in <module>
         main()
       File "/usr/share/virt-who/virt-who.py", line 505, in main
         if not virtWho.ping():
       File "/usr/share/virt-who/virt-who.py", line 228, in ping
         return self.virt.ping()
     AttributeError: HyperV instance has no attribute 'ping'
                                     ^^^^^^^^^^^^^^^^^^^^^^
   It should not return any error and virt-who can running as expected.

3. For Problem 3:
   (1) modify VIRTWHO_INTERVAL=3 in /etc/sysconfig/virt-who, and then restart virt-who service.
   (2) create a snapshot for one VM in Hyper-V
   (3) check the log of /var/log/rhsm/rhsm.log, a new uuid will be sent by virt-who, which is the snapshot's.

   Is the uuid of the snapshot needs to be sent?
  
Actual results:
As listed above.

Expected results:
For Problem 1:
  It should be "HYPER-V options:"
For Problem 2:
  It should not return any error and virt-who can running as expected.
For Problem 3:
  Please help to check if it's correct the uuid of VM's snapshot is sent by virt-who?

Additional info:
Comment 1 Radek Novacek 2012-10-17 05:32:17 EDT
This bug has been fixed in virt-who-0.8-3.el6.
Comment 3 lzhuang 2012-10-18 05:28:54 EDT
Verified version:

# rpm -qa|grep virt-who
virt-who-0.8-3.el6.noarch

1. 
# virt-who --help
......
  Hyper-V options:
  ^^^^^^^  It's correct now.

    Use this options with --hyperv

    --hyperv-owner=OWNER
                        Organization who has purchased subscriptions of the
                        products
    --hyperv-env=ENV    Environment where the Hyper-V belongs to
......

2. 
# virt-who --hyperv --hyperv-owner=ACME_Corporation --hyperv-env=env1 --hyperv-server=10.66.13.142 --hyperv-username=Administrator --hyperv-password=qwer1234P -d -i 1
WARNING: Listening for events is not available in VDSM, ESX, RHEV-M or Hyper-V mode
DEBUG: Hyper-V url: http://10.66.13.142:5985/wsman
DEBUG: Virt-who is running in hyperv mode
DEBUG: Starting infinite loop with 1 seconds interval
DEBUG: Using NTLM authentication
DEBUG: NTLM authentication successful
                    ^^^ The command is successfully executed without any errors

3. Create a snapshot of a VM, the UUID of the VM will not change, the uuid of the snapshot will not be sent.

Moving it to VERIFIED.
Comment 5 errata-xmlrpc 2013-02-21 04:50:50 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0374.html

Note You need to log in before you can comment on or make changes to this bug.