Bug 866895 - Can't reclaim space
Can't reclaim space
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-10-16 05:32 EDT by Kamil Páral
Modified: 2015-08-11 17:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 10:23:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log (8.93 KB, text/plain)
2012-10-16 05:32 EDT, Kamil Páral
no flags Details
ifcfg.log (641 bytes, text/plain)
2012-10-16 05:32 EDT, Kamil Páral
no flags Details
program.log (198.94 KB, text/plain)
2012-10-16 05:33 EDT, Kamil Páral
no flags Details
storage.log (441.22 KB, text/plain)
2012-10-16 05:33 EDT, Kamil Páral
no flags Details
anaconda.log (7.24 KB, text/x-log)
2012-10-18 08:47 EDT, Petr Schindler
no flags Details
program.log (111.34 KB, text/x-log)
2012-10-18 08:49 EDT, Petr Schindler
no flags Details
storage.log (378.22 KB, text/x-log)
2012-10-18 08:49 EDT, Petr Schindler
no flags Details
syslog (133.50 KB, application/octet-stream)
2012-10-18 08:50 EDT, Petr Schindler
no flags Details

  None (edit)
Description Kamil Páral 2012-10-16 05:32:16 EDT
Description of problem:
I have a laptop with some existing disk layout (from F18 Beta TCx). There is no free space. I enter partitioning dialog, hit Continue, hit Reclaim space, mark all partitions to be deleted. Anaconda says "you have now plenty of space". Hit OK, and on the main hub there is again an error indicator near the partitioning icon. I open it, it says I don't have enough space. I hit reclaim space, and I see all my 4 partitions again. I repeat the cycle, mark them as delete, next, next. Doesn't help. Reclaiming space doesn't work for me (probably just for this disk layout, I've seen it working elsewhere).

Version-Release number of selected component (if applicable):
F18 Beta TC4 Live
anaconda 18.16

How reproducible:
with that particular disk layout probably always, but I erased it eventually, so I don't know whether I can reproduce

EDIT: I tried for the second time, with a default disk layout from F18 Beta TC4, and this bug didn't happen

Steps to Reproduce:
1. have 4 partitions, try to reclaim space and continue installation
Comment 1 Kamil Páral 2012-10-16 05:32:55 EDT
Created attachment 628058 [details]
anaconda.log
Comment 2 Kamil Páral 2012-10-16 05:32:58 EDT
Created attachment 628059 [details]
ifcfg.log
Comment 3 Kamil Páral 2012-10-16 05:33:01 EDT
Created attachment 628060 [details]
program.log
Comment 4 Kamil Páral 2012-10-16 05:33:05 EDT
Created attachment 628061 [details]
storage.log
Comment 5 Kamil Páral 2012-10-16 05:44:18 EDT
This violates

 The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above 
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria

but it's very hard to check, because I don't know how to reproduce. But maybe anaconda developers will see the problem from the logs.
Comment 6 Jesse Keating 2012-10-16 11:59:51 EDT
Once you've removed the existing partitions, did you click the button above those to autocreate new partitions for the install?  That's what you need to do in order to get autopartitioning layout on your disks.  Please try that and let us know if it works.
Comment 7 Kamil Páral 2012-10-17 03:58:09 EDT
I haven't used custom partitioning at all, I used the simplified dialog for reclaiming space. After marking all partitions to be Deleted and hitting Reclaim space, I was told I have plenty space to install Fedora, so I hit Continue, I was taken to the main hub, but partition spoke icon showed an error. I repeated this twice.
Comment 8 Jesse Keating 2012-10-17 14:40:16 EDT
Ah, ok.  Honestly I wasn't even aware of that simplified dialog until last night testing some other things.

I think this is similar to a bug I hit last night, and valid.
Comment 9 Petr Schindler 2012-10-18 08:47:44 EDT
Created attachment 629355 [details]
anaconda.log
Comment 10 Petr Schindler 2012-10-18 08:48:36 EDT
I hit the same problem as described in comment 7
Comment 11 Petr Schindler 2012-10-18 08:49:13 EDT
Created attachment 629356 [details]
program.log
Comment 12 Petr Schindler 2012-10-18 08:49:38 EDT
Created attachment 629357 [details]
storage.log
Comment 13 Petr Schindler 2012-10-18 08:50:21 EDT
Created attachment 629358 [details]
syslog
Comment 14 Fedora Update System 2012-10-19 21:31:18 EDT
anaconda-18.19-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.19-1.fc18
Comment 15 Fedora Update System 2012-10-19 23:49:48 EDT
Package anaconda-18.19-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.19-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16528/anaconda-18.19-1.fc18
then log in and leave karma (feedback).
Comment 16 Kamil Páral 2012-10-23 10:23:00 EDT
Since I don't know any way how to reproduce this bug, I can't check it is fixed. If Anaconda developers didn't see anything fishy directly from the logs, let's just close it.
Comment 17 Leslie Satenstein 2015-08-11 17:25:07 EDT
I had a previous Linux on the /dev/sdc.  I wanted to reclaim space and then continue with the installation.

Anaconda does not allow one to reclaim space unless one is using automatic partitioning. (I needed to merge two adjacent partitions)

This is the anaconda version that comes with 

Fedora-Workstation-netinst-x86_64-23_Alpha_TC2.iso

Please reopen. I know that the statement, No changes until a "go" to begin installation is activated means that the proposed space reclamation has to be managed until ... that begin installation is activated.

I believe this is a low level bug, as I switched to anaconda's live (F2) terminal mode and did my partition merging before returning to anaconda.

I was able to merge the partitions without rebooting.  

If I did not have the knowledge of command line actions, I would have abandoned network-installation mode.
Comment 18 David Lehman 2015-08-11 17:56:53 EDT
(In reply to Leslie Satenstein from comment #17)
> I had a previous Linux on the /dev/sdc.  I wanted to reclaim space and then
> continue with the installation.
> 
> Anaconda does not allow one to reclaim space unless one is using automatic
> partitioning. (I needed to merge two adjacent partitions)

You can remove partitions in the custom storage spoke.

> 
> This is the anaconda version that comes with 
> 
> Fedora-Workstation-netinst-x86_64-23_Alpha_TC2.iso
> 
> Please reopen. I know that the statement, No changes until a "go" to begin
> installation is activated means that the proposed space reclamation has to
> be managed until ... that begin installation is activated.
> 
> I believe this is a low level bug, as I switched to anaconda's live (F2)
> terminal mode and did my partition merging before returning to anaconda.

What, exactly, do you believe is the problematic behavior? If you went to the shell and did storage changes there, the only way to have the installer adjust to those changes is through the "rescan" button in the custom storage spoke.

> 
> I was able to merge the partitions without rebooting.  
> 
> If I did not have the knowledge of command line actions, I would have
> abandoned network-installation mode.

Why, exactly? You say you wanted to merge two partitions. Does that mean "remove both and make a new one" or "remove the second and extend the first to occupy the space previously occupied by the second"? Both of these are fairly straightforward to accomplish using the installer.

Note You need to log in before you can comment on or make changes to this bug.