Bug 866952 - "DTD Validation failed:" building with Publican
"DTD Validation failed:" building with Publican
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 07:39 EDT by Joshua Wulf
Modified: 2014-10-19 19:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 21:42:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-10-16 07:39:46 EDT
Spec ID 7069

Publican output:
DTD Validation failed:
topics/Create_Message_Route_from_Source_Broker_to_Backup_Broker.xml:56: validity error : IDREF attribute linkend references an unknown ID "Configure_Queue_Replication_on_the_Backup_Broker-1"


#grep "<section" en-US/topics/Configure_Queue_Replication_on_the_Backup_Broker-1.xml 

<section id="Configure_Queue_Replication_on_the_Backup_Broker-1-1" remap="TID_7030">


==============================
Generated Details:

Package: cspclient-0.27.5-1.noarch

OS: Fedora release 16 (Verne)

JAVA: java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) Client VM (build 21.0-b17, mixed mode, sharing)
Comment 1 Lee Newson 2012-10-16 16:06:16 EDT
0.27.5 wasn't tested properly and was only prepared for you as a dev release (hence why it isn't in the normal repo), I'm not surprised it has some bugs. But either way I'll take a look.
Comment 2 Lee Newson 2012-10-16 17:39:36 EDT
I was unable to replicate this using a fairly similar environment. I'll try and setup the same environment and see if I get the same issue.

Details:

CSP ID: 1069
CSP Revision: 319370

OS: Fedora release 16 (Verne)

JAVA: java version "1.7.0_06-icedtea"
OpenJDK Runtime Environment (fedora-2.3.1.fc16.2-x86_64)
OpenJDK 64-Bit Server VM (build 23.2-b09, mixed mode)
Comment 3 Lee Newson 2012-10-17 00:16:23 EDT
I'm not sure exactly why this was working on my machine, however when I tested on my test VM I was able to replicate it.

I've also fixed the issue. The cause was from altering the underlying Spec Topic collection when performing some validation to ensure that two topics don't exist with the same ID but different revisions. This caused the spec topics to be duplicated when they were being added for building.

Note You need to log in before you can comment on or make changes to this bug.