Bug 866957 - system fails to boot because timer expires for systemd-cryptsetup
system fails to boot because timer expires for systemd-cryptsetup
Status: CLOSED DUPLICATE of bug 861123
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-16 07:57 EDT by Petr Schindler
Modified: 2012-10-17 08:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 07:17:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of console after boot fail (14.28 KB, image/png)
2012-10-16 07:57 EDT, Petr Schindler
no flags Details
journalctl file (836.00 KB, application/octet-stream)
2012-10-16 07:59 EDT, Petr Schindler
no flags Details

  None (edit)
Description Petr Schindler 2012-10-16 07:57:47 EDT
Created attachment 628133 [details]
screenshot of console after boot fail

Description of problem:
When I want to boot a system which is on encrypted partion and I don't provide a password quick enaugh (it waits less then 40s) it will fails to boot.

It falls to dracut console.

This is what I can see in console as last message (the whole screen is attached as picture):
[DEPEND] Dependency failed for Basic System

Version-Release number of selected component (if applicable):
systemd-194-1.fc18.x86_64
Fedora-18-Beta-TC4-x86_64-DVD

How reproducible:
always

Steps to Reproduce:
1. Install system on encrypted disk
2. Boot system and don't provide the password for disks
3. Wait about 40s
  
Actual results:
Boot falls to dracut console

Expected results:
Systemd waits for user action

Additional info:
I propose this bug as nice to have. System should wait for password (or another user action) and shouldn't fail to boot after few seconds of waiting. When user turn on the pc and go to make some coffee he shouldn't return to machine which looks like it is broken.
Comment 1 Petr Schindler 2012-10-16 07:59:06 EDT
Created attachment 628134 [details]
journalctl file
Comment 2 Michal Schmidt 2012-10-17 07:17:17 EDT

*** This bug has been marked as a duplicate of bug 861123 ***
Comment 3 Harald Hoyer 2012-10-17 08:23:56 EDT
Another incarnation of this bug is fixed by:
https://admin.fedoraproject.org/updates/FEDORA-2012-16223/dracut-024-1.fc18

Note You need to log in before you can comment on or make changes to this bug.