This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 866958 - nm-conection-editor editor crashes when no VPN plugins are installed (that's e.g. the case for Live CD)
nm-conection-editor editor crashes when no VPN plugins are installed (that's ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: network-manager-applet (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Blocker/F18FinalBlocker
  Show dependency treegraph
 
Reported: 2012-10-16 07:58 EDT by Jirka Klimes
Modified: 2016-01-04 01:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 14:37:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jirka Klimes 2012-10-16 07:58:29 EDT
When no VPN plugins are installed and you run nm-connection-editor and click "Add" button to add a new connection, the editor crashes with error:
"Unknown type NMVpnPluginUiInterface specified in treemodel new_connection_combo_model"

The workaround is to install a VPN plugin.
Comment 1 Fedora Update System 2012-10-16 08:06:43 EDT
network-manager-applet-0.9.7.0-3.git20121016.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/network-manager-applet-0.9.7.0-3.git20121016.fc18
Comment 2 Kamil Páral 2012-10-16 08:12:39 EDT
Jirka says an automatic connection to wifi network works on LiveCD, but you can't set it manually. Might be a final blocker.
Comment 3 Fedora Update System 2012-10-16 13:43:46 EDT
Package network-manager-applet-0.9.7.0-3.git20121016.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing network-manager-applet-0.9.7.0-3.git20121016.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16227/network-manager-applet-0.9.7.0-3.git20121016.fc18
then log in and leave karma (feedback).
Comment 4 Adam Williamson 2012-11-22 14:37:31 EST
The update was pushed stable, and I just tested in Beta RC1, cannot reproduce - booting live desktop, running nm-connection-editor and clicking Add works fine. Closing.

Note You need to log in before you can comment on or make changes to this bug.