Bug 866969 - httpd needs restart post ipa-adtrust-install
httpd needs restart post ipa-adtrust-install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freeipa (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rob Crittenden
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 08:29 EDT by Steeve Goveas
Modified: 2013-01-14 21:24 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 21:24:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steeve Goveas 2012-10-16 08:29:03 EDT
Description of problem:
If freeipa-server-trust-ad is installed after ipa server is installed and configured, httpd needs a restart post ipa-adtrust-install is run. This is for additional python modules to be loaded into httpd on IPA initialization. 

Version-Release number of selected component (if applicable):
freeipa-server-trust-ad-3.0.0-2.fc18.x86_64
freeipa-server-3.0.0-2.fc18.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Dmitri Pal 2012-10-16 10:59:48 EDT
Correct ticket is https://fedorahosted.org/freeipa/ticket/3185
Comment 3 Namita Soman 2012-10-22 07:57:52 EDT
Closing dupe of bug 866966, and ipa tkt 3185

*** This bug has been marked as a duplicate of bug 866966 ***
Comment 4 Sumit Bose 2012-12-19 06:00:56 EST
I reopened the bug, because it is not a duplicate. It is for Fedora and not for RHEL. The Fedora spec file for freeipa needs the httpd restart fix as well.
Comment 5 Fedora Update System 2013-01-04 04:25:02 EST
freeipa-3.1.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/freeipa-3.1.0-2.fc18
Comment 6 Fedora Update System 2013-01-04 15:25:08 EST
Package freeipa-3.1.0-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freeipa-3.1.0-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0171/freeipa-3.1.0-2.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-01-14 21:24:57 EST
freeipa-3.1.0-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.