Bug 866975 - Spinner eats CPU when animating
Spinner eats CPU when animating
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 09:12 EDT by Milan Crha
Modified: 2012-11-19 06:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 10:15:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Crha 2012-10-16 09:12:41 EDT
I just installed F18 alpha and did an update. I run evolution which is using gcr-prompter for password prompts and I realized one of my core is busy. 'top' showed that it's XOrg and gcr-prompt making it unhappy. This is both with gnome-shell and fallback mode, while with gnome-shell also the gnome-shell itself adds itself to CPU eating, thus it looks like two cores are busy, while the UI only waits until my password prompts is finished.

My simple test showed that this is something with UI, because if I switch to a terminal (Ctrl+Alt+3), then the CPU is happy again, while going back to graphical UI CPU usage goes immediately up again.

Another test with the Spinner gtk3-demo shows that it does it, the spinner causes high CPU usage.

This is with gtk3-3.6.0-1.fc18
Comment 1 Milan Crha 2012-10-16 09:16:52 EDT
One more note, staying in GUI and moving to other Workspace (fallback mode) doesn't help with CPU usage decrease, one might move to text console to let it be low.
Comment 2 Cosimo Cecchi 2012-10-16 10:15:47 EDT
This should be https://bugzilla.gnome.org/show_bug.cgi?id=684639 which is fixed in GTK 3.6.1 - it will be in updates-testing soon together with the rest of GNOME 3.6.1.
Comment 3 Milan Crha 2012-10-17 03:39:26 EDT
Thanks, I'll check it out as soon as it'll be available in updates-testing.
Comment 4 Milan Crha 2012-10-19 05:23:33 EDT
It's better with gtk3-3.6.1, but still unacceptable. The spinner demo eats about 8% of CPU when the two spinners animate. The gtk3-3.4.4 eats none CPU when animating the spinner. I'm moving to the upstream bug report.

Note You need to log in before you can comment on or make changes to this bug.