Bug 866983 - Unable to enable repos for EUS product [NEEDINFO]
Unable to enable repos for EUS product
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Corey Welton
: Triaged, ZStream
Depends On:
Blocks: 896265
  Show dependency treegraph
 
Reported: 2012-10-16 09:32 EDT by Tom McKay
Modified: 2014-09-18 11:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 896265 (view as bug list)
Environment:
Last Closed: 2014-09-11 08:28:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
mhulan: needinfo? (tomckay)


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2012-10-16 09:32:11 EDT
Description of problem:

The repo listing for a class of entitlements called EUS (Extended Update Service) cannot be fetched. This blocks the user from seeing and enabling the repos, which in turn prevents sync'ing.
Comment 3 Ivan Necas 2012-11-01 15:02:13 EDT
The problem with the EUS manifest is that no repository is accessible with the certs in the manifest: there is no way ho Katello could get the listing files.

The problem is that in CFSE it's all or nothing: when one repo is not accessible, the whole import fails. We can make the rule less strict, skipping the unavailable repos, but I'm not sure it's such a good idea, because the user expects the products that he has in the manifest to see in Katello. Therefore the solution is, in case such a manifests exists, to generate new manifest without the products that cause this issue.
Comment 4 Ivan Necas 2012-11-01 15:54:35 EDT
Based on https://bugzilla.redhat.com/show_bug.cgi?id=852910#c10 I suggest postponing this issue to 2.0  with either release note for 1.1, that EUS products need to have corresponding products included in the manifest, or better not generate such manifests in customer portal: all the content in the manifest should be accessible.

Skipping the content that is not doesn't solve the issue, since the user expects to see those products that included in the manifest
Comment 9 Marek Hulan 2013-01-29 10:34:52 EST
I changed this behavior in commit https://github.com/Katello/katello/commit/f7938ea06c40d50e16f3923b90d927a7b200ec75 so now it won't raise error, just inform user via green notification. Also products without repositories should be visible now.

More info in pull request https://github.com/Katello/katello/pull/1456 and wiki https://fedorahosted.org/katello/wiki/ManifestImportErrorHandlingDesign

Could you please check whether this change solves this bug? If yes, it should be moved to POST since it's already in katello master.
Comment 10 Marek Hulan 2013-01-30 09:14:51 EST
I just realized that this PR merge made Red Hat repositories page not working in headpin mode. Fix is in new PR https://github.com/Katello/katello/pull/1479 that is awaiting for review and merge. I'll add git hash when it's merged.
Comment 13 Corey Welton 2014-08-01 12:24:24 EDT
Verified in Satellite-6.0.4-RHEL-6-20140730.0 -- EUS content can be selected and synced
Comment 15 Bryan Kearney 2014-09-11 08:28:42 EDT
This was delivered with Satellite 6.0 which was released on 10 September 2014.

Note You need to log in before you can comment on or make changes to this bug.