Bug 866992 - GPU cannot resume from suspend/hibernate/vt-switch
GPU cannot resume from suspend/hibernate/vt-switch
Status: CLOSED DUPLICATE of bug 849347
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 09:52 EDT by redhat
Modified: 2013-01-21 07:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-21 07:43:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description redhat 2012-10-16 09:52:18 EDT
Description of problem:
When resuming from suspend or hibernate or switching back to x after switching vt. Screen flickers in a loop.

Version-Release number of selected component (if applicable):
7.0.0 - 0.7.20121015gitbd9e2c064.fc18 (but has been there before!)

How reproducible:
nearly everytime (it worked a few times from those many tests i did, but same settings did not work just a minute later, so it was kind of random)


Steps to Reproduce:
1. Suspend (via Gnome or pm-suspend)
2. Resume
  
Actual results:
Screen flickers, unuseable!

Expected results:
Resume...

Additional info:
Mobility Radeon HD 4200
Smolt: https://bugzilla.redhat.com/attachment.cgi?id=628097
Comment 1 redhat 2012-10-16 09:54:01 EDT
Error messages (dmesg):

Sep 26 22:54:10 localhost kernel: [ 1252.770614] radeon 0000:01:05.0: GPU reset 
succeeded, trying to resume
Sep 26 22:54:10 localhost kernel: [ 1252.783900] [drm] PCIE GART of 512M enabled
 (table at 0x00000000C0040000).
Sep 26 22:54:10 localhost kernel: [ 1252.784482] radeon 0000:01:05.0: WB enabled
Sep 26 22:54:10 localhost kernel: [ 1252.784486] radeon 0000:01:05.0: fence driv
er on ring 0 use gpu addr 0x00000000a0000c00 and cpu addr 0xffff88022a200c00
Sep 26 22:54:10 localhost kernel: [ 1252.817338] [drm] ring test on 0 succeeded 
in 0 usecs
Sep 26 22:54:12 localhost kernel: [ 1254.101427] [drm] ib test on ring 0 succeed
ed in 0 usecs
Sep 26 22:54:12 localhost kernel: [ 1254.103015] [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -35!
Sep 26 22:54:12 localhost kernel: [ 1254.105886] radeon 0000:01:05.0: GPU reset succeeded, trying to resume
Comment 2 redhat 2012-10-16 12:49:51 EDT
This seems to be kernel related. I tried kernel from fedora 17 install media and it worked!
Comment 3 Matteo Settenvini 2012-10-17 20:05:32 EDT
I can confirm the same issue on a Thinkpad X121e with a: 

00:01.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Wrestler [Radeon HD 6310] (prog-if 00 [VGA controller])

Kernel driver in use: radeon

Also for me, it's a couple of weeks at least I see this issue. Trying to switch to another console does not work. The only "solution" I have found is holding down the power button and restarting.

The kernel from Fedora 17 is okay for me, too. Oddly enough, trying to open gnome-terminal and using "pm-suspend" does not result in a problem on resume, while closing the laptop lid and waiting for automatic suspension does.
Comment 4 redhat 2012-10-27 21:39:39 EDT
seems fixed in 3.6.3-3.fc18.x86_64?
Comment 5 Matteo Settenvini 2012-10-28 12:40:38 EDT
Looks much better to me, but still not fixed. I can get this issue about one time in 20 with kernel 3.6.3-3. Probably a race condition is still present somewhere?
Comment 6 Kevin MacPherson 2012-12-31 06:43:13 EST
I've just had this on a resume using 3.6.11-3 on a Samsung RV515-A01 using radeon on a 6310HD.
Comment 7 Matteo Settenvini 2013-01-11 12:37:45 EST
Had gone away, but resurfaced with the latest 3-4 kernel revisions. Now running 3.7.1-5.fc18.x86_64, I hit this bug around ~50% of the times I resume from suspend. Only solution is an hard reset.
Comment 8 redhat 2013-01-21 07:43:17 EST

*** This bug has been marked as a duplicate of bug 849347 ***

Note You need to log in before you can comment on or make changes to this bug.