Bug 867020 - Consider using adwaita theme by default
Consider using adwaita theme by default
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
: 913157 917128 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 10:49 EDT by Ray Strode [halfline]
Modified: 2014-06-16 15:48 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 04:11:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2012-10-16 10:49:08 EDT
The Adwaita firefox theme (done by our own Garret LeSage) integrates very well with the Fedora desktop.  It would be good to consider using it by default.

Some irc discussion:

<halfline> stransky: hey, what's your thoughts on switching firefox to use the adwaita theme by default?
<halfline> so it's more integrated with the desktop i mean
<stransky> halfline, I guess it's not a technical question and I don't have strong opinion here. You can file a bug for that and attach pros and cons there.
Comment 1 Elad Alfassa 2012-10-17 06:39:20 EDT
Basically, we would like to have this theme as a subpackage or a separate package, and have it default only for the desktop spin.

The pros:
Firefox will look more like a native GNOME applications, resulting better and more consistent user experience across the GNOME desktop.

The cons:
We must make sure the theme always up to date and runs on the latest Firefox, because we don't want to suddenly revert users to the Firefox default theme in the middle of the release cycle. This used to be a bigger problem, but the development team of the theme grew since then, and I don't think it is likely that they will be too much problems in this area.

I'm not sure on the technical details, but we somehow need to make the theme only default for the desktop spin. Is that possible?

See mailing list discussion here:
https://lists.fedoraproject.org/pipermail/desktop/2012-August/007612.html
https://lists.fedoraproject.org/pipermail/desktop/2012-September/007635.html



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Martin Stransky 2013-02-26 04:11:46 EST
The Adwaita theme for Firefox has some bugs (like bad window redraw) and it does not work with Firefox themes (Personas). So we're not going to ship it as a default Firefox theme.
Comment 3 Ray Strode [halfline] 2013-02-26 14:58:23 EST
Maybe we can get Garrett to fix the issues
Comment 4 Martin Stransky 2013-02-27 03:30:47 EST
The other thing is that the Adwaita theme looks really specifically and does not fit well to other environments shipped in Fedora. IMO the default firefox theme looks more neutral and fits better to various themes. So I prefer to keep this neutral look in Fedora instead of bend it for one particular theme.
Comment 5 Garrett LeSage 2013-02-27 06:26:53 EST
## About bugs

Martin, it would be nice if you could report these issues on our upstream bug tracker for the theme. The team and I am not aware of these specific issues you mention. Please open bugs and provide some details so we know what to fix.

Here's a direct link to create new issue reports:
https://github.com/gnome-integration-team/firefox-gnome/issues/new


## Defaults

The default version of Fedora uses GNOME 3. It would make Firefox fit in more with it. Of course other spins (such as KDE) shouldn't use it. If something is shipped by default in the official desktop version, it shouldn't necessarily be shipped in alternate versions of Fedora.

Adding other desktops using RPM also know how to remove RPM themes.


## Helping out

Also, any help to make the theme better is welcomed. If you'd like to have a hand at fixing issues, we'd love the additional support.

Naturally, reporting bugs, mentioning feature ideas, and making mockups are all things to help. If you understand CSS and some level of web development and want to pitch in to directly help out with the theme too, even better.
Comment 6 Ryan Lerch 2013-03-01 16:09:44 EST
I really think the CLOSED WONTFIX needs to be rethought here.

Currently our default web browser, on our default desktop environment does not have the same theme as the other default applications.

What is stopping us from shipping this and enabling it by default? The spins can easily choose not to include and enable the theme, right?
Comment 7 Ray Strode [halfline] 2013-03-01 16:25:09 EST
well one complication is we probably would need to ship it with the main firefox package so that when security updates come out the theme doesn't break.
Comment 8 Ray Strode [halfline] 2013-03-01 16:32:11 EST
maybe we could get it pushed upstream as the default theme when running under gnome? Martin, do you think that would fly upstream?
Comment 9 Martin Stransky 2013-03-04 10:10:09 EST
Upstream ships one default theme for all DE (Gnome 2/3, KDE, XFCE, Mate...) and allows users to personify the browser with lightweight themes. It would be tricky to ship a special theme for Gnome3 only.

Even if Mozilla want's to ship Adwaitha theme as default (I highly doubt so, there's only one GTK/Linux maintainer at Mozilla) it still has some bugs and does not allow to personify the browser which is main and very popular Firefox feature.

Instead of the Adwaitha theme I push to the Firefox GTK3 port which may solve all the issues (https://bugzilla.mozilla.org/show_bug.cgi?id=627699). It's more likely to have the GTK3 FF than the special Gnome3 theme in upstream package.
Comment 10 Martin Stransky 2013-03-15 06:11:24 EDT
*** Bug 917128 has been marked as a duplicate of this bug. ***
Comment 11 Martin Stransky 2013-03-15 06:16:49 EDT
*** Bug 913157 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.