Bug 867040 - Unable to deselect products in Red Hat Repository
Unable to deselect products in Red Hat Repository
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 11:26 EDT by Thom Carlin
Modified: 2013-03-27 16:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 15:24:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 810395 None None None 2012-10-16 11:26:17 EDT

  None (edit)
Description Thom Carlin 2012-10-16 11:26:17 EDT
Description of problem:

Products with the check box grayed out which need to be deselected

Version-Release number of selected component (if applicable):

CloudForms 1.1 beta

How reproducible:
Not able

Steps to Reproduce:
1. Unable to reproduce (so far)
  
Actual results:

Products with check box grayed out

Expected results:

Be able to deselect product

Additional info:

There were errors sync'ing the repos which cause promotions to fail.  When attempting to deselect product, found they were grayed out.
Workaround is to use CLI to remove products.  Possibly related to 810395
Comment 3 Jason E. Rist 2012-11-14 23:55:46 EST
I am not able to reproduce.
Comment 4 Justin Sherrill 2012-12-18 15:24:34 EST
They should only be grayed out if the repo has been promoted, which it sounds like it had been.  

So in your case if you had de-promoted it (using a deletion changeset), you should have been able to deselect it to disable/hide it.

I am going to go ahead and close this.  If you have any issues with the above steps or you think some feature needs to be added, please reopen. 

Thanks,

-Justin

Note You need to log in before you can comment on or make changes to this bug.