Bug 867053 - Background image change only applied after re-login
Background image change only applied after re-login
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: mate-file-manager (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 12:00 EDT by Marcus Moeller
Modified: 2012-10-30 05:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: mate-control-center-1.4.0-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-30 05:09:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2012-10-16 12:00:36 EDT
Description of problem:
I am trying to change the desktop background on a Fedora 18 setup with the 'Mate desktop' package group installed.

The change only gets applied after re-login.

I am not sure if this is handled by caja but I got mate-file-manager-1.4.0-7.fc18.x86_64 installed.

The only error log I found was in .xsession-errors:

(mate-appearance-properties:12632): capplet-common-WARNING **: Couldn't load window manager settings module `/usr/lib64/window-manager-settings/libmarco.so' (/usr/lib64/window-manager-settings/libmarco.so: cannot open shared object file: No such file or directory)

maybe that's related.
Comment 1 Rex Dieter 2012-10-16 12:19:05 EDT
could be, that file (libmarco.so) is from mate-control-center.  I'll look into it
Comment 2 Rex Dieter 2012-10-16 12:20:39 EDT
Yeah, should be fixed in 

https://admin.fedoraproject.org/updates/mate-control-center-1.4.0-9.fc18

%changelog
* Tue Oct 16 2012 Leigh Scott <leigh123linux@googlemail.com> - 1.4.0-9
Comment 3 Fedora Update System 2012-10-16 12:20:53 EDT
mate-control-center-1.4.0-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-control-center-1.4.0-9.fc18
Comment 4 Fedora Update System 2012-10-16 13:44:05 EDT
Package mate-control-center-1.4.0-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-control-center-1.4.0-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16230/mate-control-center-1.4.0-9.fc18
then log in and leave karma (feedback).
Comment 5 Marcus Moeller 2012-10-16 16:02:20 EDT
Have not seen the libmarco.so bug again, but wallpaper changes are still not applied directy.

I have verified it on two setups, installed with Beta TC4 DVD and Netinstall.
Comment 6 Marcus Moeller 2012-10-17 07:32:31 EDT
It seems that caja is started with the --no-desktop option. Perhaps that's the reason why desktop background image changes are not applied immediately.
Comment 7 leigh scott 2012-10-18 06:44:03 EDT
(In reply to comment #6)
> It seems that caja is started with the --no-desktop option. Perhaps that's
> the reason why desktop background image changes are not applied immediately.

Please file this separate issue against mate-file-manager as caja draws the desktop.
Comment 8 leigh scott 2012-10-18 06:45:35 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > It seems that caja is started with the --no-desktop option. Perhaps that's
> > the reason why desktop background image changes are not applied immediately.
> 
> Please file this separate issue against mate-file-manager as caja draws the
> desktop.

Reassigned to mate-file-manager
Comment 9 Fedora Update System 2012-10-18 15:00:20 EDT
mate-file-manager-1.4.0-12.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mate-file-manager-1.4.0-12.fc18
Comment 10 Fedora Update System 2012-10-18 15:01:11 EDT
mate-file-manager-1.4.0-12.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mate-file-manager-1.4.0-12.fc17

Note You need to log in before you can comment on or make changes to this bug.