Bug 867054 - dhcp6 support fixes
dhcp6 support fixes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnsmasq (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tomáš Hozza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-16 12:03 EDT by Gene Czarcinski
Modified: 2013-01-12 10:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-26 23:39:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
allow reuse of ipv6 addr (1.26 KB, patch)
2012-10-16 12:05 EDT, Gene Czarcinski
no flags Details | Diff
remove uncessary tests (2.06 KB, patch)
2012-10-16 12:06 EDT, Gene Czarcinski
no flags Details | Diff
permit multi instances of dnsmasq with DHCPv6 service (1.47 KB, patch)
2012-11-03 08:56 EDT, Gene Czarcinski
no flags Details | Diff
eliminate filters which prevented valid DHCP6 requests from being serviced (2.44 KB, patch)
2012-11-03 09:01 EDT, Gene Czarcinski
no flags Details | Diff
from dnsmasq-2.64, fix access control for dhcpv6 (2.61 KB, patch)
2012-11-08 07:08 EST, Gene Czarcinski
no flags Details | Diff

  None (edit)
Description Gene Czarcinski 2012-10-16 12:03:52 EDT
Description of problem:
There are currently two problems with dnsmasq 2.63 which I have worked with the dnsmasq developer to identify and fix.  The first fix has been added to the dnsmasq git and the second was just submitted.  I expect to see both of these fixes in dnsmasq 2.64.

First problem:  You can only run one dnsmasq dhcp6 server on a system.  The first instance gets excluside use of the ipv6 address.  When the second instance starts it cannot get exclusive use and fails because "the other guy" has it.  Solution: "don't do that"

Patch attached.

Second problem:  Dnsmasq will not respond to any dhcp6 requests if --listen-address is specified instead of --interface.  In supporting dhcp6, there was some incorrect and unnecessary tests done which made dhcp6 requests be dropped unless --interface for the network interface being supported was specified.  Solution: remove the tests.

Patch attached.

Version-Release number of selected component (if applicable):
dnsmasq 2.63

How reproducible:
easy ... every time

Steps to Reproduce:
1.
2.
3.
  
Actual results:
dnsmasq either fails startup or just does not work

Expected results:
it works

Additional info:
Comment 1 Gene Czarcinski 2012-10-16 12:05:41 EDT
Created attachment 628246 [details]
allow reuse of ipv6 addr
Comment 2 Gene Czarcinski 2012-10-16 12:06:42 EDT
Created attachment 628247 [details]
remove uncessary tests
Comment 3 Gene Czarcinski 2012-10-16 12:07:29 EDT
One other thing ... these patches were developed on 2.63.
Comment 4 Fedora Admin XMLRPC Client 2012-10-22 09:21:09 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Gene Czarcinski 2012-10-22 09:38:33 EDT
Regardless of what is done with 2.63, these updates are part of 2.64 now in development/testing.
Comment 6 Gene Czarcinski 2012-11-03 08:56:21 EDT
Created attachment 637482 [details]
permit multi instances of dnsmasq with DHCPv6 service

Slightly updated so that it matches the changes now integrated into dnsmasq-2.64.

DHCPv6 support is in the process of being developed for libvirt which uses multiple instances (one per virtual interface) to provide dns, DHCP4, and DHCP6 services.  While this support in libvirt will be post 1.0.0, it is anticipated that there will be backports to F17.  SInce it is unlikely that F18 will have dnsmasq-2.64, it is recommended that this patch be applied there also.
Comment 7 Gene Czarcinski 2012-11-03 09:01:05 EDT
Created attachment 637483 [details]
eliminate filters which prevented valid DHCP6 requests from being serviced

This is an updated version of the patch I originally submitted and now matches the code changes the dnsmasq developer made for dnsmasq-2.64.

Again, this patch is needed so that the DHCPv6 support currently under development for libvirt will work.

Both of these patches do not change any current functionality of dnsmasq.
Comment 8 Gene Czarcinski 2012-11-08 05:25:05 EST
Hello ... anyone looking at this?

There sure was a hurry to get dnsmasq-2.63 into F17, F18, etc.  Now, how about fixing so that DHCPv6 actually works for libvirt!
Comment 9 Tomáš Hozza 2012-11-08 05:49:16 EST
Hi Gene.

Sorry for the delay, I didn't have much time in the last days to review your patch, but I will get to it and let you know.
Comment 10 Gene Czarcinski 2012-11-08 07:08:40 EST
Created attachment 640770 [details]
from dnsmasq-2.64, fix access control for dhcpv6

I just check and made absolutely sure that these submitted patches were backported from dsnmasq-2.64 via the dnsmasq git.  They are now exactly as in 2.64  and when applied to 2.63, the rpm builds clean plus it works.  I have tested this although I am mostly running dnsmasq-2.64test7 now.

Simon said that he hopes to have 2.64 out "real soon now" and I recommend that, when it is out, it should go. to F18 and your choice on F17.  In the mean time, dnsmasq-2.63 plus these two patches would be very helpful for libvirt.
Comment 11 Gene Czarcinski 2012-11-08 16:33:26 EST
OBE.  I will leave this open but libvirt is going to require dnsmasq 2.64 or later for DHCPv6.  Since dnsmas 2.64 should be out "real soon now" according to Simon Kelly, I suspect that there will be a push for it on at least F18 if not also on F17.

If you want to close this, that is fine with me.
Comment 12 Fedora Update System 2012-11-19 07:25:36 EST
dnsmasq-2.63-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dnsmasq-2.63-2.fc17
Comment 13 Fedora Update System 2012-11-19 07:29:26 EST
dnsmasq-2.63-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-17789/dnsmasq-2.63-3.fc18
Comment 14 Fedora Update System 2012-11-19 14:34:23 EST
Package dnsmasq-2.63-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnsmasq-2.63-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17789/dnsmasq-2.63-3.fc18
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-11-26 23:39:48 EST
dnsmasq-2.63-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-01-12 10:24:46 EST
dnsmasq-2.65-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.